Servers by jDrones

SITL and X-Plane

Hi guys,

I am new in this community, I am pretty much interested in the SITL and X-Plane. I wanted to ask a few questions about that.

If I understand well I can use the SITL and mission planner in order to create a flight plan on X-plane and make my helicopter follow it? I would only need X-plane, AMP and the STIL, no hardware would be needed?

thanks

Chris

Yes, You understand everything right, You dont need any hardware, just computer.
Every step to run SITL is well showed in the wiki:

http://ardupilot.org/dev/docs/sitl-with-xplane.html

Just follow every step.

Or You can run scripts from /Tools/autotest/win_sitl/ folder.
Take a look at readme.txt

Since You will download latest copy of ardupilot code, You can use either Xplane 10 or 11.

Nikita.

Hi,

I tried to follow every step to install SITL and mission planner http://ardupilot.org/dev/docs/sitl-native-on-windows.html#id8, I don’t know why but I don’t see any simulation and terminal icon when I run the Mission planner program.
any ideas? is there something I missed?

Chris

Hello, Chris, it is hard to diagnise what is wrong, since You didnt post any screens or text of cygwin output, or maybe You didnt installed something, we need more info.

Nikita

Hi, actually I found out why I could not get those icons, it was just about an option I did not check in the parameters.
However, I still cannot connect my mission planner to X-plane.
I followed those 2 tutorials as you suggested
http://ardupilot.org/dev/docs/sitl-native-on-windows.html
http://ardupilot.org/dev/docs/sitl-with-xplane.html

I think everything went pretty fine. but when I get to mission planner I do not see any X-plane connection option.
see the first file attached is what I see and the second what I am supposed to see according to the tutorial.

here is how it is on my cygwin when I run the sim vehicule

I also get a map as it is showed on the tutorial

Also when I try to run the plane or quadcopter from the simulation option on mission planner I get this

thanks for your help

chris

I try to assume that You installed and set everything rigth.

Open Cygwin. (We will build copter)

cd ~/ardupilot/ArduCopter
make sitl -j4

You will build firmware for first time
In order to start SITL with Xplane, move to desired platform (we build copter)

cd ~/ardupilot/ArduCopter
sim_vehicle.py -j4 -D -f xplane-heli --console --map

Now if everything is right, You will see also MAVProxy window
Now start Xplane, once he will be ready, You will see data in MAVProxy.

Now open MP, choose UDP connection and press CONNECT. You will see window promt with 14550 port. Press ok, after that MP will connect to MAVProxy, which is connected to xplane.

Now You can control your copter with MP.

Take a look at the bottom of the wiki, since You need to setup helicopter with two additional requirements.

Nikita.

so hmm does now X-Plane work with ArduCopter?

Andy

I am also interested in using SITL copter with X-Plane. Have not been able to do it. Have plane working fine. Can X-plane work with ArduCopter?

Hi

Does Ardupilot SITL also work with X-Plane 11?

Thank you in advance.

Best Regards, ryma

Hi

I installed APM for Mac OSX, then the FTDIUSB SerialDriver.
Then I entered the UDP port in APM Setup.
However, I am not connected to X-Plane. I always get the following message:
“Please connect first.”

Can someone help me how to connect to X-Plane 11?

Thank you in advance.

Best Regards, ryma

You might be able to use the XPlaneConnect interface to hook up each throttle output from the MAVLink protocol…? But it requires original work as far as I can tell… in the language of your choice, C, Matlab, Python, etc.

Servers by jDrones