Servers by jDrones

Single & CoaxCopters with AC3.5

Copter-3.5 (in beta testing at the time of this post) includes the Single Copter and Coax Copters in the main multicopter firmware. This means if you load up the AC3.5-rc1 (or later) quad copter, you can actually fly a single-copter or coax-copter.

Set FRAME_CLASS to “8” for SingleCotper or “9” for CoaxCopter and then restart the board.

Also the servo and motor mappings list on the wiki are out of date (we will update them before the AC3.5 release):

  • Servos 1 to 4 should be connected to Outputs 1 ~ 4.
  • Motors should be connected to 5 and/or 6.

I’m building a small single copter. I read conflicting information whether ArduCopter will properly run on the Pixhawk Mini. Are you able to confirm yes or no?
If not, what small size hardware can I use to run ArduCopter in a single copter mode?

I have used PixHawk Mini in my single rotor project. I am approaching to PID tuning stage specific to my frame. So far I found Copter software performing fine. I mean, at least, steering surfaces are moving in direction which suppose to keep vertical position of the frame.

jaco, I am able to get my flaps and rotors to respond to manual control, but I can’t get any auto-stabalizing/auto movement. Yaw control is not working at all. Any idea what I’m missing? I’m thinking it’s an issue with how I have my servo output functions assigned in mission planner. Thanks.

We connected all servos and motor as instructed in the article linked in your another post (copter and coax-copter). It means servos on channels 1-4, motor on chanel 5.
We did not change any channel assignments in Mission Planner.
To get auto motors and fins response you need to arm autopilot and set motors (just a little bit) above idle settings. Then moving on vehicle - by hands - you suppose to observe fins and motors in action trying to keep vehicle vertically.
In CoaxCopter case transmitter yaw right causes no change in fin movement but motor speed changes that’s why you suppose to arm the system to see/hear this.
Hope this will help you but it’s only my guess.

Jaco, thanks, I got it working because of your advice. I didn’t realize Mission Planner auto assigned the outputs as long as I had them hooked up in the correct order. Also I didn’t realize I had to arm the the copter to even get an output signal to the motors, so in my testing it was looking like I only had servos. As soon as I just hooked it up as instructed, armed it, and tried it, it worked like a dream!

The only thing I’m having trouble with now is yaw control. The copter is rotating fairly quickly and trim seems to have no effect. I’ll look through all the guides and settings, and motor calibrations, and see if I can find any obvious mistake. Other than that though everything works, flaps and all!

Thanks.

I noticed this:
http://www.ascentaerosystems.com/spirit
A commercial implimentation, and powered by Pixhawk Cube & Arducopter

Hello! I’m working on a coaxcopter and had some problems.
Could you please tell me how to set the correct servo_function of channel 1 to 6?
My default settings of the servos are ‘disabled’…
Thank you very much.

As requested:

http://ardupilot.org/copter/docs/singlecopter-and-coaxcopter.html

Servers by jDrones