Simulator won't start simulating

Total Newbie here…
I just installed mission planner, followed the tutorial for creating a mission plan with a couple of waypoints. Opened the simulator, picked a plane with quadplane frame. Back in the planner, I selected “write”, the message tab states flight plan received. I set the mode to Qstabilize, and then selected Arm. Message tab states throttle armed. I set the mode to Auto, and in the message tab I see “Mission: 1 WP”, and nothing happens. If it matters, my mission has 2 waypoints, and a RTL. What am I doing wrong? Do I need to actually load a firmware file? I was hoping for an “OOTB simulation”.
Any help is appreciated

  • Phil

Did you reboot after setting the frame ? If you don’t the simulation is a regular plane and is not able of doing a vertical takeoff. In Flight data press ctrl+f and reboot, then reconnect in the upper right corner and try again. Also you have to choose a qtakeoff and an alt as a first wp unless you takeoff an other way.

Hi, Alex… thanks for the response! No, I did not reboot after setting the frame. That did seem to get things moving. Question, when you say “Also you have to choose a qtakeoff and an alt as a first wp unless you takeoff an other way.” Do you mean that I should add qtakeoff as the first step in the mission plan, or that I should select qtakeoff as the mode in Flight Data instead of qstabilize? And what does add “alt as a first waypoint” mean?
Thanks again!

1 Like

Set AUTO_OPTIONS=3 to allow arming in auto mode and takeoff without raising throttle. This works for Copter and should also work for VTOL takeoff.

Your first waypoint must be QTAKEOFF with a non-zero altitude.

You cannot use QSTABILIZE without connecting a joystick.

Hi, Yuri… thanks for the response! First of all, where do I find “AUTO_OPTIONS”? I do not see it in the full parameter list. Also, “QTAKEOFF” is not an option in the list of waypoints in the planner. Finally, Alex mentioned that I need to reboot after setting the vehicle. When I press ctl-F I see an option for “Reboot Pixhawk”… is that the right selection?

Again, my goal with this exercise was just to be able to run a simulation… I don’t care what type of vehicle / frame, etc… All help is greatly appreciated!

Thanks again.

  • Phil

Yes it is the right selection

Then starting with a quadplane is definitely not the easiest exercise !

Start with a rover arm it discover the guided mode, the manual mode, the auto mode, the way mission planner works to plan missions, you have plenty of tutorials. Quadplanes are not the easiest vehicles to master since they combine quadcopter and planes functions to be able to make a vertical takeoff

The default configuration for Multirotor will run a Mission w/o any additional settings or configuration. But, unless you have some RC input, a Joystick as Yuri said or a Transmitter with a USB connection, you will have to use Auto Or Guided mode.

Plan a simple Mission like this:
Then from the messages screen Arm in Stabilize, switch to Auto and from the Do Action pulldown select Mission Start and answer the dialog box. It’s flying.

After that if you want to start the Mission quicker set some of the AUTO_OPTIONS parameters. They are self explanatory from the Set Bitmask screen.

Thank you, Alex and Dave for the responses!
Using a rover was definitely more successful. However, in the Planner, I do not see “TAKEOFF” as a command option. Even when I rt-click on the map and select Takeoff, it asks for a takeoff altitude (odd for a rover in my thinking), but then it just generates a row with Waypoint as the selection. On the Data tab I was able to set the mode to Auto and the mission completed successfully. YAY! Any thoughts on the first command being WAYPOINT instead of TAKEOFF?
Thanks again.

  • Phil

The Mission commands are vehicle type dependent. If you want to use the Takeoff command load Multirotor which was the example I gave.

1 Like

Got it… thanks again!