Servers by jDrones

Simulation run too fast

Hi All,
I have set up the SITL environment according to basic setup on the web. Everything was fine and working, but the plane is a bit fast in simulation. I have tried to look at “time” command in MAVProxy and I have found that autopilot clocks diverge from the GCS clocks and run 10x faster. The same observation was done in ArduPlane window:
Rate: target:1200.0 achieved:13063.5 speedup 10.9/1.0

I have tried --speedup=1 option, but without any effect.

Thanks for any suggestions.

Hi, I am experiencing the same (copter), I have an install running in wsl (speedup 16.2/1.0, so hanging on tight). In Ubuntu 18 all works. It’s observed in mavlink SYSTEM_TIME.time_unix_usec.
Did you investigate this further?

The speedup can be changed with SIM_SPEEDUP param, 1 should be real time

Hi Peter,
Thanks for the reply. There seems to be a problem with the system time in wsl, which is faster (10-20 times). I do not see this when running on linux. SIM_SPEEDUP will not alter this even if I reduce it to 0.1 to match. I will look at it some more as I am not that familiar with running this in windows.

Speedup works as expected from me on both WSL1 and WSL2, I’m not sure what could be causing your issue.

I reinstalled to ubuntu 18 on wsl1 (from ubuntu 20 on wsl1), and it works fine now.
Rate: target:1200.0 achieved:1198.7 speedup 1.0/1.0
Not sure what happened here, if its the os version or something in my previous install. Thanks again.

Hi all and thank you for reply. That is what I have forgotten to remind, that my system is also WSL2 with Ubuntu 20. It looks like the same problem. I will try to put it on Ubuntu 18 and reply if it also works for me.

I want to third this post. Unintentionally set up SITL Simulator within WSL2 with Ubuntu 20.04. Ran into the same accelerated simulation issue. Sim SpeedUp Scaling attempts have no impact.

Do devs have any idea why this issue occurs?

Servers by jDrones