SimpleRTK GPS compass configuration

I have the ArduSimple simpleRTK2B+heading kit that includes the simpleRTK2B and simpleRTK2Blite. Both boards are configured using the configurations provided by ArduSimple and the simpleRTK2B is outputting UBX-NAV-PVT and UBX-NAV-RELPOSNED over the JST connector to a Pixhawk 4’s GPS connector. The PH4 is running Ardupilot.

In Mission Planner, it appears that I have a 3D dgps fix as well as rtk fixed (when outside). But the compass/yaw is still only affected by the position of the PH4. I’ve tried numerous parameters to 1) try to disable to magnetometer-based compass and 2) use the heading value from the UBX_NAV_RELPOSNED signal as the compass and I can’t achieve either.

ArduSimple says that the PH4 w/ Ardupilot can’t understand the UBX commands and that I need something to parse the data to NMEA. I don’t feel like that’s accurate, as it seems like the RTK signal is recognized.

I have also tried this ( and couldn’t get anything to work.

Does anybody have an experience with this? I feel like it’s either not currently possible OR really simple and I’m overlooking something.

Have you looked at this discussion?