Servers by jDrones

SimpleBGC, MavLink control, Yaw


(dany) #21

I was not able to get it workong other way, but I will try once again … and what did you ment by support 360yaw ,
isnt it controlerd by MP in full 360yaw range …


(Nathaniel McMahon) #22

I’m having the same issues you were when connecting alexmos via mavlink.
Wondered what settings you went with? I’m getting no response with my parameters
Here’s my parameters:

Alexmos___
mavlink tab:
channel 1 = rx-serial (using mrpro yaw and aux 3 pins connected to rx,tx)
sys id/comp = 1, 154
port = 115200, none partiy
send hearbeat = yes

Rc settings tab:
Roll-pin mode = sbgc serial_api
roll pitch yaw etc all set to no imput

Arducopter___
SERIAL2_BAUD = 115
SERIAL2_PROTOCOL = 1
BRD_SER2_RTSCTS = “0”

( serial SR3 does not necessarily correspond to serial 3 just the 3rd Mavlink port enabled in order used (usb SR1, telemetry 1 SR2, telemetry 2/alexmos SR3)
SR3_EXTRA1 = 20
SR3_POSITION = 5
SR3_RC_CHAN = 20
all other SR3_ parameters set to 0.

MNT_type=4
MNT_RC_IN_TILT=6


(Nathaniel McMahon) #23

It seems simpleBGC GUI mavlink tab : channel 1 serial port: RC_serial is the wrong setting to use. without anything connected I get AHRS: ok and loads of packets received, none lost, no parse errors. How is that possible?
I’m trying to use yaw and aux3 pins as rx,tx. Should I be using serial port: UART2 instead?
Because I’m getting no communication doing that


(Danijel Petrović) #24

I did try all combinations , but only after pluging it via uart2 all parameters and control stareted working


(Nathaniel McMahon) #25

Right, same here. Tried every combination multiple times, I’ve contacted HDair Studio but they haven’t gone into any detail. Just said it’s possible with tilt and roll pins which it don’t believe it is.
What pins/board contacts did you wire to for UART 2?


(Danijel Petrović) #27

sorry to keep you waiting for so long … I was long off line …

I have conected mavlink tx/rx to rc roll and rc yaw directly on left side inputs of BGC (not servo pin connections , but on wires )


(Nathaniel McMahon) #28

No worries can you show me where exactly? Not sure from that description. What settings did you have in simplebgc to connect with that.


(Danijel Petrović) #29

on the left side of board there are solderd wires ( brown- GND , orange -
5v , yellow - RC yaw , green - RC roll , light blue - RC pitch , aux3 ,
aux2 ,aux1 ) , actualy I have put mavlink on that rc yaw (mavlink tx) and
aux3 (mavlink rx) …

As a rule, flight controllers have several telemetry ports operating at
MavLink protocol. To connect the gimbal, you have to choose a free port and
set baud rate not less than 115,200 in the autopilot settings, since the
gimbal controller requests a large amount of data at a high frequency. In
ArduPilot responsible for this parameters:


(Danijel Petrović) #30

SERIALx_BAUD = 115

SERIALx_PROTOCOL = 1,
where ‘x’ is a port number.
Do not choose value 7 (alexmos), when working over MavLink protocol! Correct value is 1 (mavlink).

Additionaly, set data rates for this port:

SRx_EXTRA1 = 20

SRx_POSITION = 5

SRx_RC_CHAN = 20

all other SRx_xx parameters should be set to 0.

From the SimpleBGC32 side, you can choose UART1 port (connecting GND - GND, Rx - Tx, Tx - Rx), but in this case, GUI USB connection will not work together with the MavLink connection, excepting “Tiny” board. An alternative option is to choose the second UART on RC_ROLL input (Rx) and RC_YAW input (Tx). For the encoder-enabled version, use AUX3 (Rx) and RC_YAW (Tx).

The SimpleBGC32 controller supports up to two MavLink channels. Activating only one of them is necessary. In the GUI tab “MavLink” you must choose which serial port to use for this interface. The main port is UART1; the alternative is RC_SERIAL. Next, you need to select the parameters of the serial port, which shall comply with the autopilot settings: "115200, none parity ".


(Danijel Petrović) #31

and affter doing all that , if still not working , there is option in simple BGC
Swap RC_SERIAL <-> UART2 ports (ver. 2.60+) - this option swaps RC_SERIAL and UART2 ports and in my case that is when magic hapend and all started working


(Danijel Petrović) #32

just be patiant ,I have lost servel days on trying to make it work … it will start working eventualy …


(Simon Cozzolino) #33

Nathan- if you haven’t got your gimbal working yet- I spent the whole day yesterday struggling to get to grips with this.

You say you’ve got no inputs in your RC settings tab- it’s my understanding you need to click the drop downs for say, PITCH and set the input to “API_VIRT_CH_x” where x is your RC input channel number. try that to get a response. I got control working hours before the GUI told me mavlink was talking. I’m using 2.66b2 (beta) and it needed lots of restarts to refresh it’s data.


(Emanuele Della Volpe) #34

Dear All…

I’m using the gimbal ARRIS cm3000 (SimpleBCG32-Alexmos). I’m practice the wiki of ardupilot which is about gimbal connection --> (http://ardupilot.org/copter/docs/common-simplebgc-gimbal.html#commo…).

During the BaseCam SimpleBGC software setting all works fine about the frame follow mode (enabled for the yaw and disabled for the pitch and roll)…

than, when i connect to the “Telemetry2” port, the remote controll seem to be right about DO_MOUNT-CONTROL orientation (command of Mission Planner GCS for the yaw, pitch and roll gimbal orientation) but the problem is the inconsistence between the yaw reference angle of the gimbal that does not follow the frame yaw during the fly… it should be ever the same…

I would be grateful if you could help me to understand how is possible that the gimbal works fine for the FOLLOW YAW exclusively when it is not connect to the Pixhawk. In fact just when i connect on the “telemetry2” port of pixhawk the gimbal lost its follow mode for the yaw and keeps to point a wrong specific direction ( like pitch and roll)…

somebody have never get good controll results using Alexmos protocol…? do you think that I have to leave this way ?

every advice is very helpful…thank’s lot.
Emanuele


(Simon Cozzolino) #35

Hi Emanuele,

You have encountered the MAV_CTRL_MODE parameter. This tells the board how to behave IF it’s plugged into to your telem 2 port and getting a mavlink heartbeat. Remember, as the manual states, in mavlink control mode on the first DO_MOUNT command, rc control will be disabled and as you describe, the gimbal will just point at it’s roi.

There are 3 options:
0- disabled, regular RC targeting
1-allow mavlink to control roll and pitch only
2-allow mavlink full control

You can set this up to a potentiometer or a 3 position switch on your tx to change it in the air if you wish.

In basecam GUI, goto the mavlink tab and find the field marked " mavlink control mode" and select disabled. Now the gimbal will follow frame but still receive AHRS from the FC.


(Emanuele Della Volpe) #36

Hi Simon,
thank’s a lot for the answer…

are you considering that i’m using Alexmos protocol and not mavlink…( in ARDUPIOLT: SERILAx_PROTOCOL=7[alexmos] , MNT_TYPE=3[alexmos])… In other way, is your advice adptable to the current protocol i use ?

thank’s a lot,
Emanuele.


(Simon Cozzolino) #37

oops, no sorry.

Alexmos serial does work really well. Ignore my advice but I’ll leave it up for anyone searching who has the problem who is using Mavlink.
I’ll make a set up next week and try to replicate your error.

Make sure stabilize pan is checked in your gimbal screen in mission planner.
If that doesn’t work, while connected to mission planner set mount to rc targeting- if it starts to follow yaw, change your MNT_DEFLT_MODE to 3- RC targeting.


(Tim Jones) #38

currently searching for a mini pro, ready to throw my storm32 in the kibitz drawer


(OldGazer) #39

What problems are you having? I have a STorM32 and it works just fine…


(Tim Jones) #40

Storm only really works if you use openbeta a fork of arducopter. Not interested in forks
probably not the thread for that long discussion