can't find Mavproxy.exe

I’m trying to install the windows version on Win10 and all directions worked until i get ready to start it by typing -j4 --map. Can anyone help? The program and directory are there, but the path is program files\mavproxy… no (x86)

$ -j4 --map
~/ardupilot/Arducopter ~/ardupilot/Arducopter
Building sitl
Starting up at CMAC : -35.363261,149.165230,584,353
Starting ardupilot : /home/longtallcool1/ardupilot/Arducopter/Arducopter.elf -S -I0 --home -35.363261,149.165230,584,353 --model --speedup=1
Window access not found, logging to /tmp/ardupilot.log
Unable to start ‘C:\Program Files (x86)\MAVProxy\mavproxy.exe’: The specified file was not found.

you don’t have MAVProxy installed or it’s not been set on your path


Yes, I do have it installed. Reread my previous comment. Mavproxy is installed, but its not in the program files (x86) directory, it’s in the program files directory. I just followed the defaults, and that’s where it put it. How do I tell it not to look in the (x86), as the error states, but look in just the program files…
I could put another path statement, I guess, but it would be nice to have it look in the right place first.

This is the same error windows access error that I have been getting, and like you I have Mavproxy installed too, but I didn’t look at where it was installed.
Is it just a case of moving Mavproxy from the program files directory to the program files (x86) directory, or modifying the installation path, how would I go about modifying the installation path?
Thanks, Martin.

1 Like