Servers by jDrones

Sim_vehicle.py --map --console does nothing aside from printing start and kill tasks

Hello, I’ve been trying to run SITL on windows through cygwin (as what is told in the documentation). I’ve gone through the set up in order, from downloading cygwin, clone the git, download mavproxy (though the latest mavproxy has some issues that I installed the previous version, which cant be run if the master args isn’t meddled with (auto connect and failed to 0.0.0.0:14550)), and run ../Tools/autotest/sim_vehicle.py --map --console

the terminal only printed

SIM_VEHICLE: Start
SIM_VEHICLE: Killing tasks

and nothing happen.

here’s the screenshot of it:
https://pasteboard.co/JjQ9Smh

as you can see, i’ve tried adding parameter to the mavproxy to run at master=127.0.0.1:14550 in which port mavproxy is able to run. any guess what might be wrong?

im trying to run SITL on flight gear, but this issue hindered me. thank you!

General syntax that I use successfully with FlightGear is the following:

sim_vehicle.py -C -v ArduPlane -f jsbsim:[MyAircraft] -j4 -L [MySite] --console -w --add-param-file=“[MyParam.parm]”

The bracketed entries are to be replaced by aircraft and airport of your choice. Example:

sim_vehicle.py -C -v ArduPlane -f jsbsim:Rascal110 -j4 -L KFSO --console


I think you need to start with at the least the following basic line specifying whether you will run ArduCopter or ArduPlane:

sim_vehicle.py -C -v ArduPlane

If it works hen you can add more options to override default entries.

If above line still fails try adding -c flag to recompile everything from scratch. Make sure the compilations ends with success.

Use -h flag to see the full set of entry options for sim_vehicle.py.

thank’s for the reply. the thing is, im trying to run the first step of doing SITL from windows (which is this step https://ardupilot.org/dev/docs/sitl-native-on-windows.html#running-sitl). That step alone i can’t manage. And i’ve tried your line, it still prints the same and do nothing.

im trying to rerun the setup how-to from the docs step by step now

edit:
Rerun the SITL setup from the beginning is the best choice. now SITL is working! Though, I curious about this messages
which: no osascript
RiTW: Window access not found, logging to /tmp/ArduPlane.log

i tried installing osascript through pip in cygwin, but one of the dependency raise this error
platform cygwin is not supported so i didn’t continue the osascript installation.

if anyone can answer, it would be appreciated. but if not, then it’ll be for next time then.

anyway, thank you!

Servers by jDrones