Error using SITL with Vagrant

Hello everyone,

I have been setting up SITL using Vagrant following this article. My VM is artful32 and following the steps I end up in /Vagrant/ArduCopter and run -j 2 using the absolute reference /vagrant/Tools/autotest/ -j -2. This returns the following error.

After reviewing this forum I found similar issues where the solution has been to run git submodule update --init --recursive. I retried while making sure that I ran git submodule update --init --recursive both as a regular user and using sudo. Both times I received the same error. After going through the forums I have been unable to find a similar issue so I thought I would post. Please let me know if you have any suggestions.


Using sudo where not required can horrendously break things…

Does /vagrant/modules/waf/waf-light exist?

Note that the instructions do include a direction to do the git submodule update --init --recursive within the Vagrant environment.

I tried using git submodule update --init --recurisve before trying it with sudo. I will have to go back because on an old forum post there was a recommendation to use sudo. I checked and waf-light does no exist in the specified folder. One thing I do notice is that I receive no confirmation in the bash prompt that the update is doing anything. No text is show on the screen and it typically runs in <1 second. I’ve included a picture of my /vagrant/modules/waf/waf-light folder as well of me running git submodule update --init --recursive.

Yeah I saw that the instructions direct you are supposed to git submodule update --init --recursive… I just missed it the first time.

OK, a couple more things to try:
ls -la /vagrant/.git (make sure nothing is owned by root)
git submodule status
git submodule deinit -f --all; git submodule update --init --recursive

The permissions on that directory are horrendous…

Sorry it took a while to get back to you, had a busy weekend.

So it looks like I have read/write permissions on my user for /vagrant/.git though it also looks like submodule doesn’t exist.