cannot pass through on Windows 7


I followed the instruction of Setting up SITL on Windows. Everything looks good until I run it.
When I run, it says “The project was not configured: run “waf configure” first!” and stopped. The details of the messages are copied below. Could you advise how to solve the problem? Thanks very much.

xql@ITW8026220 ~/ardupilot/ArduCopter
$ -j4 --map
SIM_VEHICLE: Killing tasks
SIM_VEHICLE: Starting up at -35.363261,149.165230,584,353 (CMAC)
SIM_VEHICLE: Configure waf
SIM_VEHICLE: “/home/xql/ardupilot/modules/waf/waf-light” “configure” “–board” "sitl"
Setting top to : /home/xql/ardupilot
Setting out to : /home/xql/ardupilot/build
Autoconfiguration : enabled
Setting board to : sitl
Checking for ‘g++’ (C++ compiler) : /usr/bin/g++
Checking for ‘gcc’ (C compiler) : /usr/bin/gcc
Checking for need to link with librt : SIM_VEHICLE: Building
SIM_VEHICLE: “/home/xql/ardupilot/modules/waf/waf-light” “build” “–target” “bin/arducopter” “-j” "4"
The project was not configured: run “waf configure” first!
SIM_VEHICLE: Build failed
SIM_VEHICLE: Killing tasks

xql@ITW8026220 ~/ardupilot/ArduCopter

Can you try to remove -j4 and see if it works? It should be waiting for waf configure to end, but apparently it isn’t.

Thanks for the suggestion. I removed -j4, but the error is exactly the same.

I can’t explain why the error is presenting itself like that, but (and I’m sorry I didn’t remember this earlier) right now you can’t build SITL in Windows with waf. I plan to correct that in the coming weeks. In the meantime you need to use make. So, you have to add the option --build-system=make to the sim_vehicle script. Are you using Cygwin?

After adding the option “–build-system=make” to script, the simulator works! Thank you very much.