Servers by jDrones

Silkv2 air radio doesn't communicate with Pixhawk1 (v2.4.8)

Hi,

I can not connect Mission Planner with Pixhawk using Silkv2 radio - 433Mhz 500mW (“No heartbeat packets received” message appears). SilkV2 air radio has a solid red led (firmware update mode ??).

Some clues:

  • I connect silkV2 air and ground to the same PC using USB port and I can read/connect both without problems (both ways). Leds are green in ground/air radio. Paramaters in ground/air are exactly the same (attached screenshoot).

  • I have updated silk firmware using Mission Planner.

  • Pixhawk parameters: serial_1 protocol=1 (MAVLINK1), serial_1_Baud=57 (57600), BRD_ser1 RTSCTS=2 (auto).

  • I have tried Telem1, Telem2 and serial 4/5 ports in pixhawk with same results.

I guess the problem is between the silkv2 air radio and pixhawk. Air radio has 4 pins connector and pixhawk has DF13 6 pins connector - only Vcc/Tx/Rx/NC/NC/Gnd pins connected in pixhawk side. Tx and Rx are crossed. Can someone help me to debug?

I have 3DR radios and when I power up my Pixhawk I get a green flashing LED and then later I get a flashing red LED that corresponds to the heartbeat packet.

When I connect the ground unit I get a solid green LED on both units and the red led flashes as each packet is received by Mission Planner.

Next to where I plug the USB cable in is an orange LED that flashes as each packet is received by the radio.

If I unplug the ground radio the green LED will start to flash as it lost connection. The red LED continues to flash at a much slower pace.

Don’t know if this helps.

Mike

Hi Mike,

Thanks for the clarification but my air radio module is always in solid Red (when I connect to the Pixhawk). Based on the details in Ardupilot wiki http://ardupilot.org/copter/docs/common-sik-telemetry-radio.html it means it’s in “…firmware update mode…”.

I got a 3DR clone and only inlcude 2 leds (green and red). Here you have the radio modules:

As mentioned in my last post, when I connect both radio modules (ground and air) to the same PC, first leds are blinking green and then they move to a solid green.

Any idea?

So even though they both connect with the Green LED on solid the Red LED is always solid Red. If you try to connect you don’t see the Red LED flash at all?

Since I don’t have these radios its hard to tell what’s going on.

If you hook each unit to Mission Planner and do the Load Setting button does it read the firmware information?

Mike

Hi Mike,

Let me clarify the use cases because I guess we are mixing them:

Use case 1 (2 radios connected to a PC through USB): It’s working. Green led is solid in both radios and I can read parametes coming from both radios and even I reach second radio through first radio (2 ways). Red led is not blinking. First screenshoot in the chat.

Use case 2 (radio ground connected to a PC using USB and radio air connected to a Pixhawk 2.4.8 Telem1 port). It’s not working. Radio ground has green led blinking and radio air has a solid red led.

Hope it’s clear now… and bring light to the problem

Jordi

Air radio is wrongly wired, check connections.
You can leave RTS/CTS unconnected and do not use hardware flow control.

My radio is not 3DR. Its a clone and only has 4 pins connector (RTC/CTS is not available) + USB. It’s a Sikv2 (different from sikv1 included in the schema you included). Photo shows it:

Only Vcc, Gnd, Tx and Rx are connected.

  1. Try to connect both radios to PC via FTDI or other USB/UART converter (not using built-in USB connector). Do you have same behaviour as when connected via built-in USB?

  2. Do you have solid red on AIR radio, no matter which one you’re connecting to PIX (I assume that both radios are identical)?

Same problem here,
bought one from ebay, clone 500mw.
AIR is SOLID RED, meanwhile same air radio connected to computer works fine, problem is on pixhawk config, maybe we should set some params on port? as above posted, I tried telem1 and 2, same results. Also copied configurations and confirmed 100% matching by loading settings on computer.

after random amounts of restarts, air will try to blink green and connect, once connected works fine.
see youtube video, which I’ve sent to ebay seller.

Hi Novice_2001,

I have the same problem reported in the video you attached !!!.
I have to plug and unplug the air module to the Pixhawk until green led appears. Once it appears I can connect to Pixhawk from Mission Planner.
Next step is buy an original 3DR radio…any suggestion about an online shop in Europe footprint?

Thanks for your help (iseries, mkrawcz1, novice_2001)

Well, can’t believe I am saying this but Hobby King has what you need: https://hobbyking.com/en_us/hkpilot-transceiver-telemetry-radio-set-v2-433mhz.html

Mike

Also if you want the 500mw version they have that too.

Hi,

Yesterday you showed the problem, now I have solved… half the problem (let me explain the details). I have unpluged the TX and RX cable from the 6 pins DF13 or Molex Picocable connector (not sure which connector I have) and pluged them again into the connector. Now it’s “working” (I get a solid green led in the air radio). I guess it was a HW issue.

Now the pending “half problem”. Radio-air is not working in case I power Pixhawk with the radio-air plugged.
So, when I power Pixhawk, I have a solid red led in the air radio link, but in case I unplug and plug again DF13 connector in the Telem1 port then it works (solid green led and I can communicate from ground radio - Mission Planner). It also works in case I power Pixhawk without radio-air plugged and later on I plug radio-air.

Could it be a firmware problem in Ardupilot with this specific 3DR clone? could it be related with the radio settings?. It’s clear when I power Pixhakw and radio-air is connected, then both radios can not sync (well explained in next URL: http://ardupilot.org/copter/docs/common-3dr-radio-advanced-configuration-and-technical-information.html). I have tried several settings (air speed, duty cycle…) with the same results.First screenshoot in the chat is the default setting I have in the radios.

Any suggestions?

@iseries: I’m “close” to solve the problem. I hope I hadn’t to purchase a new radio. Thanks.

This issue was reported on another thread somewhere. Radio’s only work after power the Pixhawk.

It could be that Tx or Rx are held low/high when power is applied to the radio causing it to go into configuration mode on power up. Is there anything in the doc’s about that. Well that probably is a silly question since no one provides complete documentation anymore.

Anyway I think it is the state of the pins when power is applied that is causing the issue.

I guess you could test that by power the unit on with the pins in one of these two states and see if you can reproduce the issue. Fixing it will be very difficult. Probably if the pin is held low on power up for x number of seconds is the issue.

Mike

Theoretically radio enters in bootloader mode in case “…you can force bootloader mode by shorting the CTS and GROUND pins on the radio while powering on…” (http://ardupilot.org/copter/docs/common-3dr-radio-advanced-configuration-and-technical-information.html). So it’s not related to Tx and Rx pins, although perhaps the documentation doesn’t include additional details…

Now that is partially working, I prefer not to power the unit with TX/Rx pins to VCC or GND, just to avoid irreversible problems.

Could someone confirm radio only works after power the Pixhawk?

Finally I found it !!. The FC takes some time to stabilize the power, so during this time slot, Sik radio couldn’t work.
Manufacturer confirm it and I’m waitting FC to be replaced. Meanwhile I’m working with another FC (2.4.6), although it has the 1MB limitation…

Jordi

Dear Steadyspike,

I have the same problem.
I bought new telemetry radios and gives all stable red light when power on APM.
I am using APM 2.8.
With older teletery radios works well with the same APM. So I think it is not because of the FC’s fault (APM in my case).
If you plug the micro usb and gives +5V ACC through them it will start always with green light. But will not communicate!
I think here is something about the radios.

here propose how to solve this problem http://diydrones.com/forum/topics/3dr-telemetry-always-bootloader?xg_source=activity

1 Like

In case anyone has landed on this thread, I recently had the same issue and it was a simple solution: moved the DF13 from Telem 1 to Telem 2. Not sure why that mattered, but it did!

Hi dear,

I had exactly the same problem. After checking, I found that the problem was the wrong connection of RX and TX.
you can see connection in picture…

Good Luck

1_carrier_pinout%20-%20Copy

Servers by jDrones