Sik telemetry radio immediate red light on FC side

I am running a Mateksys F405 wing and ArduPilot 3.9 with Sik radios for telemetry (915 MHz, 500mw). I got the radios off Amazon and the description is " QWinOut New 3DR Wireless Data Transmission Radio 915Mhz 500mW RX+TX Telemetry w/OTG for APM2.6 2.8 Pixhawk FPV System Antenna" so they aren’t the official 3DR brand raido and appear to be an off brand. I have it hooked up to UART6 on the F405 and the corresponding 5V pad When I plug the Lipo battery (3S) into the FC, the radio immediately has a “red light” status. If I unplug the battery and re-plug it in, then the radio goes to green and works fine from there although sometimes it takes a couple of tries for it to work. Plugging the same radio into a USB cable goes to green right away 100% of the time and plugging the other radio into the FC has the same issue. Although it does work fine eventually, it is a bit annoying to do this every time I fly. Any ideas on this one? Do I have defective radios? They are set up with Mavlink v1 and a 57600 baud rate.


I’m having this fking problem as well. were you able to solve it?

Unfortunately I have still not solved this and still have to unplug and replug in the battery, sometimes multiple times, to get it to connect. I can’t see the light with the radio installed so I have to keep trying to connect to it to see if it works, very annoying.