Sik radio with qgroundcontrol fails radio setup

I have a Holybro S500 dev kit with pixhawk 6c. I am trying to connect to Qgroundcontrol using a pair of Sik 915 mhz radios. The radio seems to pair ok and the app can see them. If I turn off the drone QGroundControl says “Communication Lost”. In QGC with the radio connected I click the calibrate button in Radio Setup and a popup appears stating “Radio Not Ready Please turn on the transmitter”… Since I cannot calibrate I cannot set Flight Modes. The power button is also read and the values shown in the popup appear to be invalid. How can I get past this problem


Have you solved your problem?

I have not. I did not get any replies from the forum before yours

Hi Bruce,
Do you have an RC radio transmitter and receiver set up?
The radio calibration screen relates to them, and not the sik radios used for data.

Maybe describe your build in a bit more detail and how you plan on using this copter.
Even a photo of the flight controller, wiring and radios might help a lot.

Thanks for your reply

I have 2 SIK 915 Mhz Telemetry Radios. One is connected to the drone / PixHawk 6c on Telem1. And the other is connected to my windows 10 computer using a USB cable.

When I power up the drone and plug the other radio into my computer the computer radio gets a flashing yellow light on the side of f the radio where the USB cable plugs in and a solid green led on the other side of the radio…

The radio on the drone has a solid green led and what appears to be a yellow flashing led under it or real close to the green one.

QGroundControl issues several warnings as shown below
prearm rc not found
prearm hardware safety switch

prearm 3d accelerometer calibration needed
prearm compass not calibrated

If I click the calibrate button on the radio tab a popup appears showing Radio Not Ready Please turn on the transmitter

If I power down the drone after lights are green then QGroundControl says communication lost so I know it does connect to the drone

I can run some of the calibration steps which shows there is communication flow.

What is the Hardware safety switch and what RC are they looking for?


Finally got the drome sensors calibrated so I am down to just the hardware safety switch and RC not found messages.

I tried putting a 2.4 Ghz receiver on Telem2 and connected to that with a Radiomaster Boxer controller but that did not help.

The drone is a Holybro S500 V2 Dev kit with Pixhawk 6c. It is a fairly simple build with only 4 cables plugged into the Pixhawk; Power / Gnd, GPS,
I/O and the 915 Ghz radio.

Try to find all the drones parameters within QGC, while the drone is connected via USB or the sik radios.
Change these settings:


That will stop the hardware safety switch messages.

You will still need a radio control transmitter and receiver, and the receiver needs to be plugged into the Pixhawk 6C port labelled “PPM/SBUS RC” before you can do that radio calibration.
You will need the RC radio link for normal control of the copter. The sik radios can send data to and from the laptop, and do “Guided” mode (click a place on the map and fly to here) but it’s not great for setting up and tuning the copter. The sik radios are great and incredibly useful once everything is working well.

1 Like

Thanks for your help. I have a Spektrum DX5E controller and a Spektrum AR600 receiver. From What I see grom Google I need to connect the receiver to the DSM port on the Pixhawk. It appears there is no voltage on the pins of the DSM port, I looked in MissionPlanner I did not find any settings for radio and when I look in QGroundControl I only saw the “Spektrum Bind” button. I tries the bind setting the DSM2 mode but that did not help. I also have a RadioMaster Boxer controller with an RP4TD receiver but I did not find how to connect that. It is a 4 bin receiver with power, ground, .TX and RX.


Dont worry about google so much or any old youtube videos, go straight to the Arducopter doco.


That receiver will still need to connect to the “PPM/SBUS RC” port on the Pixhawk via some method. Arducopter will automatically detect the RC protocol in use. Ignore the connector labelled DSM.
DSM2 is just the radio standard used between the transmitter and receiver, it’s not the RC signals that come out of the receiver to control servos or anything else.
The trouble you have is that receiver is an ordinary RC Plane job with individual channel outputs. The Pixhawk (and all recent flight controllers) are expecting one RC input with all channels combined. SBUS is ideal, but PPM and some others are OK too.

One of these might be OK as a receiver, it theoretically works with your transmitter but I’ve not seen it done:

you have a DX5E, which is only 5 channels and no longer supported.
Even if you get the receiver connected to the flight controller, you are going to struggle with just 5 channels - that’s pitch, roll, throttle, yaw, flight mode. Technically all you need for a couple of the normal flight modes, but you wont be able to set a switch as “Return to Land” or have any of the other nice functions at your finger tips.
The sik radios will give you those abilities, but reaching from your RC over to your laptop could be less than ideal.
So let us ignore all that Spektrum stuff unless anyone can help with a better solution that buying the Hobbyking receiver and trying to live with just 5 channels.

RadioMaster Boxer

This will be the way to go, future proofed but a bit harder to set up.
The receiver will need to connect to the “Telem3” port on the Pixhawk.
+5 → +5
tx → rx
rx → tx
Then there is a few other settings to do once you’ve got that far.

RC_OPTIONS,8224   -> it is probably 32 now

ELRS has channel 5 dedicated to Arm/Disarm, so during transmitter setup you can choose a switch to assign the channel 5 for easy arm/disarm, maybe too easy!

Then there will be some transmitter setup too, but we can go through that when you get to it.

Thanks for your help. I now have communications from the Boxer to the QGroundControl and can arm the drone from QGroundControl although the motors turn off after a few seconds… I cannot arm from the Boxer. I do have the props off for safety since I am indoors

You mentioned some transmitter setup that we can do. Will that include configuring the arm/disarm and the return to home?
I do not see a setting in MissionPlanner Parameter List but then there does not seem to be a search function so I may have overlooked


Getting closer step by step. I can arm the motors but the right side props spin off i.e spin reversed. I set SERVO1_REVERESD = 1 and SERVICE2_REVERSED= 1 but that did not seem to change anything.


Sorry I did not explain that well. I ran the motor test and verified each motor was in the correct position.White front right motor A or 1 (33), black back right motor 2 (34), white back left motor 3 (35) and black front left motor 4 (36). Each motor started in the correct place when I moved the motor test slider but the two motors on the right side (1 and 2) spun backwards. Setting the reverse parameter did not change anything/


Hi Bruce
Undo the SERVO REVERSED settings, as that wont change the spin direction of motors. It only swaps the direction of travel of a servo.
Depending on which ESCs you have, usually the easiest way to reverse a motor direction is to swap the position of 2 of the motor wires at the ESC - it doesnt matter which two.

The Boxer radio runs the EdgeTX open source firmware so we should be able to remotely configure this with your help. Download and install the EdgeTX Companion:

Go to the bottom of this page, where it says “Assets” select the install for your computer, like for example

See if you can connect to the radio from the Companion
Download models and settings from radio, save it to a file and attach it to our discussion. I should be able to adjust it to suit your switch choices and send back. There’ll be some matching Arducopter parameter changes.

Work out switch positions for these functions:
Arm/Disarm : maybe the new latching SE switch , or some other switch.
This switch should not be accidentally changed during flight, so dont select one you could easy hit by accident.
Motor Emergency Stop : instantly kills the motors in the event of a crash or some other event, essential during “the early days”
Flight modes : a 3 position switch, or the six buttons if you can easily select them without needing to look too hard
RTL : switch for easily selecting RTL , and it will do Land too if it’s a 3 position switch

All the switches are labelled SA , SB , SC and so on…

If you tackle the radio setup yourself these are key points:

Pitch channel must be inverted in the Direction column shown here