Servers by jDrones

SIK Radio v2 EMI problem

Hello. Could anyone suggest the solution to the problem of significant EM interference coming from sikV2 radios. I have several SiK radios and all experience the same problem when connected to pixhawk FC. NAmely, when connected to Telem1 port, the voltage readings (measured by voltage meter) become unstable and have recurrent jumps between 4.8-5.2v measured on any GND/VCC line of pixhawk peripheral ports. When the radio is disconnected, the voltage reading stabilizes to ~5.1v. I have tested two SiK radios (Holybro V2, and another one from some chinese supplier of unknown quality) on two pixhawks (Holybro Pixhawk4 and pixhawk 2.4.8).
The wiring is standard. No additional peripherals were connected during this ‘test’. Any advice is appreciated. Thank you.

Could be a problem with your “power brick” but probably best to power those radios from a separate 5v BEC.
Actually I’d be investigating to quality of supply from you power brick anyway. Logs have that information available.

I discovered that it is not a power issue. I’m using 500mw telemetry with dipole antenna. This causes severe interference across all electronics. If i remove the antenna from the module, the issue seems to disappear.

I had a similar problem with my RFD900 (actual version is RFD868x).

All servos of my helicopter were twitching like hell.
the telemetry is powered over the Pixhawk Cube telemetry connection… and so powered trough the power brick.

my interim solution: reduce transmission power.
the original setting with “30” was reduced to “20”. Servos were almost silent, but no visible movement anymore.
did some test flights and everything was fine.

but I have no solution for the full power so far. But I guess Shawn is right and there might be a power supply issue…

BTW: removing the antenna is not a good idea.

yes. thanks for your reply. This is exactly what I’m going to try and power telemetry module from a separate BEC. Power supply is not an issue as I’ve tried several power modules on several FCs and all such setups produced same results (voltage fluctuations on Pixhawk VCC peripheral lines).

Any News regarding Your issue?
Did You try to supply the telemetry from a different source?

I am also Interested in a solution with full Transmitter Power rather than reducing Power and Range in the end…

I tried with a separate power supply for the telemetry, used the servo rail from my bec (5.3v)

Still same issue…

Servos jitter like hell with full tx power of telemetry

@Pakman

I have noticed that when using the RFD x series that when hooked up just using the radio as a telemetry radio and not using the PPM passthrough that it made my servos go crazy, now that I have managed to figure out the PPM passthrough and have hooked up the PPM pins to the RC input on the flight controller have made all of the jitter go away, still get the random jitter when the gps bounces around when first turned on but nothing like it use to be when they would constantly jitter even with good GPS fix. Have you tried moving your radio to a different location or some of these ferrite rings attached to the wires.

Hi Matt,

What exactly do you mean with ppm pass-through?
Using the rfd telemetry instead rc transmitter?

I use the telemetry with qgroundcontrol And a standard rc transmitter for semi automatic flights in visual range…

I don’t have any ferrits installed so far, except one for the ESC (traditional electric helicopter setup)

If your setup is the solution, I could do a test just disconnecting the the rc receiver… And the jitter should have gone right?

Hey, could you send a screenshot of the settings you used to get PPM working on the RFD ?

I’ve got telemetry working fine, and have rfd pin 15 --> RC in (signal).
Ground SiK RC in
Remote SiK RC out

have a look at this post in here it explains the settings for using sbus which is the same as ppm except the setting sbus out compared to rc out

Be very careful you don’t try to transmit without any antenna or dummy load on the Tx output. You can destroy your transmitter because the RF power is just reflected back into the Tx. This can burn out the final amplifier stage sometimes. If operating the Tx have a dummy load fitted if you don’t want an antenna radiating the energy. This is likely to be more problematic at higher Tx power settings.

Servers by jDrones