Sik Radio TimeoutError when Load Settings [under Linux]


I just got my hands on 2 Sik Telemetry Radios from Holybro. I’m intending to connect one to my onboard Raspberry Pi computer, and the other to my PC, and testing their performance communicating through a custom protocol, so the first thing I did was running Mission Planner to see what their firmware settings were set to.

I’m running Manjaro Linux on my PC, so I got the zipped release of Mission Planner and ran it under Mono. Then, following the instructions here, I tried Load Settings, but got this error:

In the above screenshot you can also see the serial settings I use for connecting. I ensured that /dev/ttyUSB0 was indeed the correct device.

I also tried running Update Firmware (local), and it seems the firmware gets loaded correctly, at least I see the red LED blinking.

When I have the SiK radio connected to my pi it comes up as dev/serial/by-id/FTDI..... The USB ports don’t work.

Have you tried these commands

sudo usermod -a -G dialout $USER
sudo apt-get remove modemmanager -y

I’m running Ubuntu for pi, but I’m going to guess Mint should be the same since it’s ubuntu based.

1 Like

Thanks for your reply! Trying with dev/serial/by-id/FTDI... I get the same result :frowning:.

Why do I need to remove modemmanager? I work with 4G modems on the Raspberrys so I would want to avoid removing this package if possible.

Not going to pretend I understand why, but I had to remove modemmanager to get everything to work. It comes up in a couple of the installs for some GCS software. Worked for me, your mileage may vary.

1 Like