Sik radio firmware update and version question

So I have some sik radios (915 Mhz). I went into APM Planner and loaded settings fine but noticed one radio was 1.7 (ground module) and one was 1.9. Tried to flash the firmware with apm planner on the ground module but it kept saying this despite having selected the right port (sure of it):

import sys, argparse, binascii, serial, glob
ImportError: No module named serial

Complete 1
Flashing with firmware
Traceback (most recent call last):
File “./sik_uploader/”, line 6, in
import sys, argparse, binascii, serial, glob
ImportError: No module named serial

Above looks like APM planner is missing a perl module. Maybe it expect that to be installed locally on the mac?

Tried then in Qgroundcontrol and it flashed it (apparently to 2.0). However now back in APM Planner it won’t read the settings fully from what I can see. No ability to set some of the fields and also don’t load (like the frequencies). Don’t know if this is because 2.0 is beyond what APM Planner knows about or what. From serial terminal I get this for the newly flashed module:

RFD SiK 2.0 on HM-TRP

Also, I don’t get what the different options are for under Sik Radio Updater in APM Planner. It has “3dr Radio”, “RDF900a (915Mhz)” and “RFD900u (915 Mhz)”. I chose 3DR when I tried to flash but as above it was unsucessfull.

Basically, what version of the firmware should I be using for the 915 modules and what is the most reliable way to flash it? Should I just flash the other module with Qgroundcontrol also (probably to 2.0 since seems to be no control of what version there) and call it good?

Well, since this place seems dead I’ll tell you what I did. Went ahead and let Qgroundcontrol program the other one (air) and now both are on 1.20. Seem to work so far but only just synced up their settings and then went ahead and connected both to serial terminals and made sure could type back and forth and have display. Hence they have an established link. Next to try them in the neighborhood with some test software.

APM Planner can at least see both at the same time but it does not fill out all fields when reading so I think it’s somehow out of sync with the 1.20 version. Oh well, as long as they send data is all I care as ultimately I want to inject my own stuff and then demux my stuff before sending on to ground station.

Thanks for posting your solution.

im having the same trouble on my Mac, any update for the problem? I am going to run bootcamp and use mission control on windows, thats my fix so far…

Found a fix, download:
That should do it