Significant throttle delay in Alt Hold and Loiter - OK in Stab

I am unable to figure out what is going on with a very simple build utilizing Pixhawk and 3.4.4 I have a throttle delay of perhaps a few seconds in assisted modes listed above but not in stabilize. I am bench testing and only have bench test logs (attached). I am not very experienced at reading logs, but appears rc_in and rc_out confirm issue, just cannot figure out exactly what is going on and which parameter might be set wrong. I have lidar attached as well but tried bench testing with and without lidar plugged into serial 4/5 - consistent results. 34.BIN (1.3 MB)

Sounds normal. The output is processed even in Stabilize mode so there should be no expectation of RCin/RCout direct correlation. And furthur, with the craft stationary (fixed) the sensors are not receiving feedback. Fly it.

Thanks for the reply, Dave. Unfortunately the delay is so extreme I wouldn’t fly it this way. I have been using apm and pixhawk for many years now and have never experienced this particular issue. There is something fundamentally wrong…I started going through each of the parameters and comparing to defaults and a previous version from this quad. It acts like a combination dead band along with 2 or 3 second delay from the time I lower throttle to motors slowing down. Yet in stabilize, if there is a delay, it isn’t nearly as significant. Will pick it up Monday…

Jim-I did some bench testing of my F450 (Pixhawk with 3.5Rc1) and I see the same thing you report. I wouldn’t normally spin up the motors on the bench in anything other than stabilize but it behaves essentially as you have described. I’m not surprised by this and this quad is, and has been since 3.2.1, flying great.

Wow, that is interesting. With that, guess I will give it a try - worst case I crash! Actually, we have a number of quads sitting around with the pixhawk - and like you, could be I just never actually tried the bird on the bench in anything other than stabilize - even though I thought I did. This should help clear up the “mystery”. Guess the non problem is a non problem. Thanks and I will confirm on Monday. :astonished:


I had similar issues today flying AUAV-X2 with 3.4.4

In Althold and Loiter, the Copter was not holding altitude. As soon as I activate, it comes down like it tried to land.
Hovering in Stabilize was fine.


MOT_HOVER_LEARN: is set to “2” (learn and save) but the value is CTUN.ThH unchanged for the whole 10 minutes

Hi , did you manage to find the solution ?
I have the exact same problem and it is obvious that this kind of delay is not normal
I need to fix this in order to flight my drone for the first time
Thank you

Please open a new thread. And make sure you are not testing this with the copter tied down.

i opened like 2 or 3 threat and nobody managed to find a solution

Then you need to help yourself. Sometimes nobody knows the answer, so if you want one you need to find it yourself. Sorry about that, we try to help as much as we can.
But it does help a lot reading the documentation, using good hardware and doing proper tuning.