Setup telemetry at less than 19200 baud

the datasheet of module
Hello dear friends and engineers
I want to establish a telemetry communication with my autopilot through a simple radio module called RF7020D13. my question is: Can only the modules introduced in the wiki be used or can this module be used as well?
The maximum baud rate that this module can provide is 57600, but the maximum data transfer rate is 19200. Please help me, is it possible to do this? I couldn’t connect to ArdoPilot no matter what I tried, even I changed the parameters related to serial1. I use pixhawk2.4.8 autopilot.

you will end up with data loss as you will overload the radio without any flow control. try control +T to connect in read only mode so you should be able to monitor it.

1 Like

thank you for your reply but i don’t want to just monitor the drone I want to be able to set params and send commands to.
and another question? do the radios introduced in wiki use flow control?
what is your idea to solve this prob my friend?

you need to use telemetry radios designed for mavlink or that are fast enough that you cant overload them.

1 Like

It is possible though you will have to configure your GCS software to not request data streams (IIRC default configuration of MP runs at >80% load on 57600baud link) and configure message rates on the flight controller (see documentation for how to do it) and set port rate to less than 19200 so the device can’t become saturated (it is necessary as MavLink V2 frames can be larger than 255 bytes).
It will be very slow. Should be enough for use as “long range” (not really long range @20mW) telemetry and command link, control may be less than ideal.

1 Like

Do you mean that more than 80% of the bandwidth of the communication link is dedicated to sending the REQUEST_DATA_STREAM message from the ground station? Does this mean that all the messages sent by Atoilot occupy only 20% of the bandwidth? Did I understand you correctly? Thank you for your guidance. But one more question. You said that this message is sent by the ground station at a rate of 57600. Is it possible to reduce this rate? Or just disable it?

No, messages sent by the AP at the default rate that is also requested by MP use 80% of the bandwidth. You need to use a more precise way that is described in the documentation to trim unnecessary data without losing useful information.

Bandwidth utilisation on the uplink side is significantly lower most of the time. You can adjust baud rate of the serial connection in MP when setting up connection. There is a way for MP to listen only though AP won’t know about such GCS.

1 Like

thanks alot for your reply. i finally managed to connect to AP by this module and read sensors data but parameters won’t be updated.

i even set sr2_params stream rate to 0 but it’s not working yet. any idea to solve this problem?

It wont work, as it will be loosing too much data, connect using CTRL+T in read only mode, then click stats up next to the connect button and see how much data its loosing.

the radios dont even have hardware flow control so you cant throttle it that way.


Set all SR_rates for that serial port to zero. and Use at least 9600 baud. Good luck.

1 Like

Thank you very much for your time. I did what you said, interestingly we don’t have any missing data but still the parameters are not received.

It should be noted that the serial transmission rate is 4800 and the RF link transmission rate is 9600

1 Like

You also need to set stram rates in MP, otherwise Ardupilot parameters are overridden by MP. -1 is no change.

1 Like

thaaaaanks my friend
it solved the problem

Good idea, by limiting the serial port speed your forcing the data down to a rate the RF link can handle.