Setup of 900mm quadn (18 inch propellers)

That attitude control looks pretty good except for a slight overshoot in yaw.
There’s a bit of variation in altitude, could be prop-wash affecting the barometers - both baros closely match readings though, so they are equally affected by whatever the problem is. Could be wind I suppose.

The vibrations are still high and will give you trouble. If you can minimise vibrations (and you should) the tuning could get much better.

You might want to increase ATC_THR_MIX_MAN now, 0.5 is a typical value

You motor outputs are dipping to their lowest during some manoeuvres, you might even have to add a bit of dummy payload.

Probably drop the HNOTCH frequency a bit so it better covers your motor RPM range.
INS_HNTCH_FREQ,30
INS_HNTCH_BW,15

Regarding GNSS - your number of sats and HDOP is a bit erratic. Try changing GPS_GNSS_MODE so performance is more consistent for your area.
Probably a value of 5 or 65.

I did another test-flight, although this was an endurance test, just because I was curios. 35 min was the result! 6s 6000mah.

Log: https://drive.google.com/file/d/1e-JO5HeUUP1S3fVUzbxK_DPsmaKC0os3/view?usp=sharing

The gps hdop looks better here. Don’t know if it was a bad day yesterday. I didn’t change the settings you suggested for this flight, sorry for that, didn’t see the message until after I flew.

Yes, the drone would need a bit more weight to make more aggressive yaw movements, and probably for some more agile flying too. I have a 6000mah 6s on it right now. I’m planning to buy 2 6s 10000 mah batteries since I have a larger aircraft coming up. One of those might do the job. I don’t like the concept of adding dummy weight, but until I get a hold of those batteries I might have to.

The vibrations is probably my biggest issue. I don’t have much to do but I still use those soft-mounted motor mounts. I need to change them but I haven’t got any new once yet. Also, my gps mast, is one of those fold-able thin once. Maybe that could cause vibrations. I could replace it with a more robust mount just in case.

Other than that it’s not much I can do. I use a tarot 650 sport with extended arms, that frame is not the most stiff one and maybe i won’t be able to get my vibrations down low enough with this frame?

Thanks!

It’s flying quite well now after some roll, pitch and yaw tuning. Still high vibrations though. No clipping in normal flying which is good. But the motor mounts should be replaced. I’ll do that as soon as I get a hold of some new once.

Than I guess the tarot 650 with extended arms isn’t the best frame either.

Thanks for all the help!!
@xfacta
@dkemxr

@dkemxr @xfacta

Hi, I’ve mounted my motors stiff now and gotten rid of the soft-mount I used before. My vibrations are now below 30 and below 10 at hover, which is a great improvement since with the soft mounts I reached vibration levels of 60.

My issue, or well, it’s not really an issue that shows in flight performance but now, when the motors are stiffly mounted to the frame. The quad makes a very high pitch sound while flying and hovering. The sounds come from the motor rpm as it changes when I maneuver.

Is such a high pitch sound normal or should I be worried?

Log:
https://drive.google.com/file/d/1K3-pB5fh54ptXbX-of4lt1FHJvFeEzPd/view?usp=sharing

Over all it looks very good.
Try these adjustments below, but honestly I’d give Autotune a go. You can always put back the values you have now if you dont like the Autotune performance. Just save a before and after param file.

That motor noise is usually D term is too high, and you might find motors get hot. D terms can be destructive.
You could try lowering
ATC_RAT_PIT_D,0.008 to 0.00675
If the motors do get hot after a short flight then lower both pitch and roll D terms even more.
The ATC_RAT_YAW_D,0.02 could be affecting this too, I would lower it to about 0.01 (the default is zero).

Maybe lower ATC_ANG_YAW_P too, it’s usually less than pitch and roll P’s but that’s not a rule.
Also you could probably increase ATC_ACCEL_Y_MAX,20000 a couple of thousand at a time until that yaw overshoot goes away. That might be a good idea actually - lower the yaw P and increase the accel, that might help with the motor noise too.

MOT_SPIN_MIN,0.07 might need to come up a bit higher, just to ensure motors still have enough authority while descending. Try about 0.09 or 0.1 and check RCOUTs to make sure you not hitting that minimum very much during manoeuvres.

You could set
INS_LOG_BAT_MASK,0
INS_LOG_BAT_OPT,0
since you have the HNOTCH is working well.

1 Like

Thanks!!

You always give so extensive advise!

My pid values are quite unusual since I tuned it with the soft mounted motors. Now, that is’t built like a conventional drone, as it should, with everything hard mounted and stiff I think it will be ok on more normal pid settings. The high vibration also made autotune unpredictable and bad. Now, hopefully, it will give better results.

The D term in yaw was also to dampen the small overshoot. I tried your solution with the acceleration but it resulted in oscillation. Although that could also have been an effect of my high vibration and soft mounted motors.

I’ll try your advice tomorrow! Autotune will probably have to wait a couple of days as I’m planning on mounting a new landing gear. Mine did vibrate a bit sometimes, which can’t be good (it was 4 carbon rods as legs).

Thanks!

Hi Shawn,

I tried the value changes you suggested and did an autotune. The autotune seems to have failed, the drone didn’t fly that well after. The rate p was lower than before but the angle p was way higher. The rate D was also at around 0.07 which seems a bit high.

The way also had a much greater over shoot after the autotune

Log: https://drive.google.com/file/d/19VLBpl7edcm1gQM47YHWnCRuwdoGk06L/view?usp=sharing

From the log:
AutoTune: Yaw Rate: P:0.850, I:0.085, D:0.0000
AutoTune: Yaw Angle P:5.346, Max Accel:9317

AutoTune: Pitch Rate: P:0.139, I:0.139, D:0.0077
AutoTune: Pitch Angle P:18.286, Max Accel:87449

AutoTune: Roll Rate: P:0.133, I:0.133, D:0.0071
AutoTune: Roll Angle P:16.586, Max Accel:80762

Looks all OK at face value.
Have you got a log of flight after the Autotune?
I would adjust these:
ATC_ACCEL_Y_MAX,9316.907 up to about 15000 or 18000
INS_HNTCH_FREQ,35
INS_HNTCH_BW,20

1 Like

Hi, I can get you a test flight with the tuned values.

What made me question them was that my previous values were so different but worked very well. My previous tune was more smooth and slow in movements but worked great even in windy conditions.

That tune had a rate P of 0.145, an I of 0.9 and D of about 0.7. The angle P was 6.0 than. I’ve also flewn this copter with a P of 0.18 but than an angle P of 4.5.

After the autotune, I tried did a testflight (I’ll try to get a hold of the log as fast as possible) and tried to lower my D gain since I thought it was so high. Than I also tried to increase P to 0.150 which caused oscillations.

How can a value of 0.15 cause oscillations now, it didn’t before. The biggest difference would be my increased acceleration, 60 000 to 80 0000 and my angular P gain from 6 to 18. Is it so that if I increase my angular P, lower rate P values will cause oscillations?

Thanks!

I wasn’t able to get a testflight today so no log file unfortunately… sorry

I’ll try to get a testflight done tomorrow!

I did a testflight today with the new parameters from autotune. I rounded them off a little bit but basically the same.

The filter settings improved my noise levels, although there is still some oscillations going on on pitch and roll. Yaw has some overshoot as well, but no oscillations. These oscillations mainly occur with small aggressive stick inputs.

Log:
https://drive.google.com/file/d/1BhYdvwiOzne-0Z6EgdxS2dHyVDZ-IWnn/view?usp=sharing

The copter is also much more tightly tuned now. Much more responsive than with my previous tune. Although that tune didn’t cause any oscillations

Looks really good.
You should be able to set MOT_SPIN_MIN up to about 0.1
That shouldnt make any difference to the tuning at all, but you want the motors turning with enough authority to avoid any desyncs during descent, wind gusts or sudden movements.

Since you have reasonably low nose you could try AUTOTUNE_AGGR,0.05 and see if that makes a significant difference.
Keep the existing params in case you want to put them back, they can always be extracted from the .bin log file too.

If you save the params from the .bin file, you can use a text editor to trim the .param file down to just the ones you are interested in

Thanks,

I’ll back off a bit on the pid untill ocsillation stops, than I’ll do an autotune woth 0.05 aggr.

The 0.1 for mot_min is probably a good ide too

Probably avoid using AUTOTUNE_AGGR,0.05
but maybe try AUTOTUNE_AGGR,0.075
I’ve used 0.75 several times before without issue.

That’s probably a good ide.

I’ll try to find time today but it might be to windy.

Thanks

I tested autotune again with aggr 0.75. It got log quit low and strange pids. I guess manual tuning visually and with logs will be my best bet on this one.

The first autotune with 0.1 worked fine when I pulled back the values a bit. I’m going to try and fine tune it via logs and by test flying an see if I can work something out