Servers by jDrones

Setting way points isn't working


(dksmall) #1

I’m not making progress at a blistering pace, that’s for sure. Ok I’m testing the learn mode by sitting in my house and using mission planner to readback the way points. Switching to learn mode and toggling the learn switch (ch 6) doesn’t appear to do anything. I use Read WP to load the way points from the PixHawk to mission planner and nothing is there. If I create way points in mission planner and write them to the rover, then I can also read those back. Now if I switch to manual mode and toggle ch6, the way points are not erased, so I would assume it has something to do with the learn switch.

I have learn_ch = 6 (my radio is a 6 channel)
I have verified all 6 channels work as expected in the radio tuning page.
RC6 has a range of 964-2064 with a center point of 1514.
I have tried toggling low to high and high to low.
Ch5 is my mode switch and I can switch between manual, learning, and auto, verifying on the HUD.
GPS has a lock and shows the rover in the middle of my house on the mission planner screens.

What else?


(Thomas J Coyle III) #2

@dksmall,
How is your receiver attached to your Pixhawk?
Are you using a Spektrum Satellite Receiver or a PPM encoder and a regular R/C receiver?
Regards,
TCIII


(dksmall) #3

I have a Futaba T6K and I’m using SBUS. A cable is connected to the receiver at SB/6 and on the PixHawk at RC In. The receiver has been configured for SBUS, no PPM encoder.

Also found another parameter called CH7_OPTION, which can tell the system to use channel 7 for way points, but that option has already been turned off.


(gmorph) #4

Hi dksmall. When I’m in Manual mode and toggle CH6 (I changed my LEARN_CH to match yours) then all my waypoints clear. I have to click Read WPs again to see that they have been cleared.
Now the learning function you MUST switch to AUTO mode at the end of the learning process for it to store the waypoints. In other words drive along in LEARNING mode toggling CH6 to record waypoints and then once your finished go to AUTO mode so the waypoints are stored. You can then go to another mode like HOLD if you want and then click Read WPs and you should see them.
Let us know how you go.
Thanks, Grant.

Note: I’ve done a little more testing and it looks like the wp erase functionality (toggle learning channel whilst in manual mode) works intermittently. I haven’t identified the exact cause but I’ll add it to my list.

Thanks, Grant.


(dksmall) #5

Thanks for trying that out Grant. I armed the rover, put it in learn mode and toggled ch6. Drove it about 10 ft., toggled dh6 again, and then switched to auto. Actually it went to hold. Tried to readback the waypoints but there weren’t any. I assume that’s why it went to hold instead of auto. I only went 10 ft. because I’m still indoors. If I need to drive it farther to get a difference between waypoints, then I will do that later. Right now it’s still about 104 outside. Gotta love the desert!

Also tried erasing again, but that still won’t work. Can only set/erase using MP.


(dksmall) #6

Went outside and toggled ch6 while driving in learn mode, then switched it to auto. Still no waypoints. Not sure if I should be toggling ch6 low-high-low or high-low-high. Tried both ways, doesn’t seem to matter. I looked at the log files and I can see RCIN5 and 6 are moving as expected. What else can I try?


(dksmall) #7

I looked over the source code during lunch and I think I found the problem. When you changed LEARN_CH to 6, was CH7_OPTION still set to 1? I had set mine to 0 and if I read the code correctly, nothing will happen when the learn switch is toggled. CH7_OPTION needs to be set to 1, even though it’s not channel 7. The parameter should be called something like “LEARN_OPTION”, rather then a reference to CH7, which fooled me. I will try changing CH7_OPTION to 1 tonight and see if that fixes it.


(Thomas J Coyle III) #8

@dksmall,
I have looked at my Full Parameter list from ArduRover v2.50 and the CH7_OPTION parameter is indeed set to 1 and my learning switch does work correctly with that version of ArduRover.
Regards,
TCIII AVD


(dksmall) #9

Yep, that was it. I had turned off CH7_OPTION since I don’t have a 7th channel. With that option set to 1, I can now learn my waypoints. Is there a way I can request a name change for that parameter to avoid this type of confusion in the future? And thanks for all that helped!