Setting new offsets for compass #1 failed

Hi, this is my first topic so i want to helo with everyone. I’ve problem with Compas calibration.

This problem start’s when i turn my Copter on the back side. I try disable “use Auto accept” option but is still this same. Please help me.

I struggled with the same problem for 6 hours.
The error does not seem to be explained anywhere and does not come up in google searches.
It seems to be a bug in mission planner and I will file a bug report if no response here.
They may just come back and say that what ever old arducopter board you are using is not supported.
They are likely not going to help or answer here because you didn’t provide what version of what you are using here to get
the error.

Let us know what version of Mission Planner what board you have what firmware you are using and what GPS unit
you have etc. etc. The more info the better…

They are likely to just ignore the post as it is.
I just now noticed the fine print at teh stop shows Mission Planner version and arducopter version.
What board and compass are you using?
Is it internal or external?
Are you sure?

Also please let me know here what you end up doing.
Even if you do nothing.
Please come back here and follow up.

I have Arducopter 2.8 and GPS with compas Ublox Neo. I will try install older version of Mission Planner because it might be problem with program. Many people heave this same crash. Thanks for reply. In next post i let you know what is my position :slight_smile:
p.s. I update my Mission Planner version to build 1.1.6241.26047.

NEWS. Hello people. Problem has been solved. I must only install older version of Mission Planner from folder “archive”

Note: The latest (not old) APM Planner also seems to have no problem calibrating the compass.

Maybe a bug or incompatibility in new Mission Planner.

This turned out to be bug.
And was fixed it in the latest beta (just now)!

See: "setting new offsets for compass #1 failed"