Setting Mid throttle in 3.4. Where is the Mid Throttle Parameter?

I might be missing something here (it is, after all, 01:17 in the morning here where I live!), but aren’t the the parameters to the right of the equal sign in the last two equations identical?

Ok. If you say so. I will try to see if this works indeed so easily, then fine. The origins of my comments come from this thread here that lets us think it is much more complicated.

Leonard - I’m assuming that
minimum throttle radio pwm = MOT_PWM_MIN
maximum throttle radio pwm = MOT_PWM_MAX
minimum spin upon arming in pwm = MOT_PWM_MIN + (MOT_PWM_MAX-MOT_PWM_MIN )*MOT_SPIN_ARM
minimum spin in flight in pwm = MOT_PWM_MIN + (MOT_PWM_MAX-MOT_PWM_MIN )MOT_SPIN_MIN
maximum spin in pwm = MOT_PWM_MIN + (MOT_PWM_MAX-MOT_PWM_MIN )MOT_SPIN_MAX or
= MOT_PWM_MIN
(1-MOT_SPIN_MAX) + MOT_PWM_MAX
MOT_SPIN_MAX

… but just a guess.

Note that if the defaults for both MOT_PWM_MIN and MAX remain at 0 then
minimum spin upon arming in pwm = 0
minimum spin in flight in pwm = 0
maximum spin in pwm = 0

… so if PWM_MIN and MAX are undefined, then are the radiio calibrated throttle MIN and MAX values used instead?

The way I see it, the PWM MIN and MAX are just the radio calibrated values. The flight controller will not spit out pulses outside of those pulse widths. The 3 “SPIN” parameters are merely a percentage of that calibrated range. As an example, I make the math really easy by setting up the transmitter to send exactly 1.00ms to 2.00ms on the throttle channel.

So, if MOT_SPIN_ARM is 0.12, our ‘idle’ pulse after arming will be 1.12ms.
If MOT_SPIN_MIN is 0.17, the flight controller will not send anything under 1.17ms while in flight.
Then MOT_SPIN_MAX could be 0.9 if I know my ESC output saturates (max speed) at 1.90ms.

One can use an adjustable PWM generator to better understand their ESC’s pulse vs. speed behavior using a bare motor on the bench.

Undefined as 0, yes.

thanks … the light is starting to show details in the room

Ok, maybe I made a bit of a dog’s breakfast explaining it.

First up, this should have been:
spin when armed pwm = MOT_PWM_MIN + (MOT_PWM_MAX-MOT_PWM_MIN )*MOT_SPIN_ARM
minimum throttle pwm = MOT_PWM_MIN + (MOT_PWM_MAX-MOT_PWM_MIN )*MOT_SPIN_MIN
maximum throttle pwm = MOT_PWM_MIN + (MOT_PWM_MAX-MOT_PWM_MIN )*MOT_SPIN_MAX

If MOT_PWM_MIN or MOT_PWM_MAX are zero it defaults to the throttle calibration values. I prefer using the Mot parameters because it means I can bind another transmitter and calibrate my radio on mission planner without worrying about my ESC calibrations or tune.

To work out what your hover throttle should be you can just set MOT_THST_HOVER_LEARN to 2. This will set your hover throttle while you are flying. If you want to set it manually you can look at CTUN.ThO and set your hover throttle to whatever you see on average there when you are hovering. No maths needed.

I hope this helps to clear a few things up!!

1 Like

… and where can I find MOT_THST_HOVER_LEARN ? I have only MOT_THST_EXPO and MOT_THST_HOVER, no ‘_LEARN’ in 3.4.3 X8 octo, but it works…

It should be MOT_HOVER_LEARN.

I helped setup a friend’s quad and initially the throttle was very, very sensitive, lifting off at about 20% throttle stick. I assumed that the quad was thus very over-powered (it’s a 5S battery) or props were too large as with low values of the old THR_MID usually indicated this. Later after the learning had been applied it hovered at around 50% throttle-stick as expected, but there is very little throttle response from ~ 15-40% throttle stick.

Was it wrong to assume that it is over-powered due to that initial reaction?

(RCTimer 5010 360Kv motors and 15x5.5 props with 5S 8000mAh battery)

What flight mode are we talking about? Still on the ground?

Stabilize mode, still on the ground.

Randy I measured the hovering point at .29 in under the current firmware
(3.4) so I can still apply this to the mid throttle parameter, right? Do I
have to lower this by 10%. This is actually a brand new machine that never
flew with prior firmware. I was just expecting a number between 0-1000 and
so I assumed this has just been re-scaled. I assume the conversion factor
would apply if the a 290 hover point had come from firmware prior to 3.4.

Hi guys, sorry a bit of a newbie on Mission Planner and ArduCopter. I’ve used Baseflight/cleanflight and build a number of drones but never a UAV. Anyways I’m running Mission Planner 1.3.45 and dont have a clue what you guys are talking about regarding variables like MOT_THST_HOVER_LEARN or MOT_THST_HOVER or THR_MID because none of those are in 1.3.45.

Anyways I’m having big problems with my throttle in that my hover is around CTUN_ThO of .18. With that low a throttle when I move to Alt hold or Loiter it of course drops like a rock and does all sorts of crazy things.

I have tried to follow this trail but none of it seems to apply to 1.3.45 and I’m thinking of downgrading to see if I have any better luck!

my logs here: https://drive.google.com/file/d/0BwwL6D9_ZrAJOVlyZ3FDdHNlRkk/view?usp=sharing

I’m flying a 20,000 mah 3s hex with 15x5.5 props on 690kv 4810 motors. No payload so it moves like a greased pig.

Any help or pointers appreciated! Thanks in advance.

First off the Flight Controller is running 3.4.5.
Your MOT_THST_HOVER_LEARN is set to 2 for auto learn
Your MOT_THST_HOVER is set to .68 at the start which would have changed.

To find these values connect to your flight controller with Mission Planner and select the Config/Tuning Icon.
From there select Full Parameter List.

From the log file I can see that when you first switch to Altitude Hold mode you needed to raise the throttle to keep it in the air. Switching to Loiter mode was ok then. Later you switched to Stabilize mode and had to lower the throttle which would be the case for an over power copter. After that you switched a couple of times between these modes and it seem to be ok with need very little changes in Throttle. So it looks like the learn function is working.

Later you switched to Auto Tune mode with switch 7 but you did it from Stabilize mode. This needs to be done from Altitude Hold mode. I did see the copter drop when you did this.

You should open a new topic in the future so we can better track your issue.

Mike

Thanks Mike, I really appreciate the help. You mentioned relocating this trail, but where do you suggest?

Your answers are symptomatic of exactly the issue I have been having. I think there were some massive changes to the UI of Mission Planner recently. Please have a look at this directory where I have loaded up three screenshots from Mission Planner: https://drive.google.com/drive/folders/0BwwL6D9_ZrAJcGtwcHFrajBMMjA?usp=sharing

  • No Full Parameters.png” shows how I dont even have a “Full Parameters” list option
  • No MOT_THST… Parameters.png” shows how by using the Mission Planner filter feature, I can show there are no parameters labeled MOT_THST…
  • All THR… parameters.png” shows all the available parameters when using “THR” as a filter. Here you can see parameter “PILOT_THR_BHV” which I assume is how I affected the “MOT_THST_HOVER_LEARN” parameter you referenced. This items is also why I assumed “Standard Params” is the new equivalent of “Full Parameters”

So assuming I’m not doing something horrifically wrong, you can see why it is nearly impossible to follow this topic as it seems most of the parameters have been re-labeled and/or Mission Planner’s UI has been massively modified.

Sorry, you are right. There use to be a check box on the Standard screen to change the layout.

On the Planner tab there is a pull down next to Layout that has Basic in it right now. Change that to Advanced and you should be good to go.

Mike

OHHH thank you! That has opened a whole new door and my wife will be pleased to know that she wont have to talk to me during the entire weekend coming!

I also had a quick look at the variables and it seems that my MOT_THST_HOVER is still set around 0.6812016 so it seems the auto throttle mid setting didnt work.

I have the same issue. MOT_THST_HOVER is set to .41 MOT_THST_HOVER_LEARN is set to 2. Switching from Alt Hold to Stabilize causes the drone to leap upward.

@Marc_Dornan @rmackay9 did the copter shooting up after switching from a alt hold mode ever get resolved?

Thanks