Setting Flight Modes in MP

For some reason I can no longer set the Flight Modes on my CX20 OS V.525 using mp 3.2.1.
I calibrated the Radio Transmitter and it sets up ok. The Quad boots up and will arm.
Amy ideas?


You need to provide a flight log from the controller so we can see what the radio is sending and what the copter is seeing.


I just dropped this off for someone else and it may help you as well. For some reason mine just randomly stopped arming. No reason. No crash in between. No connections to MP in between. One moment it worked. The next it didn’t. I flashed the factory firmware and params and it was back to normal. Then I had to reset everything the way I liked it. I learned to export my params every time I made a change after that.

Here’s the file. It’s a zip file off my dropbox with a nova, CX20 set of params, firmware (downgrade?) and drivers for the PC to connect.

For the record, I picked these up at various places on the internet. I ran them sandboxed and all seemed fine. Malware bytes was fine and so was Defender. I didn’t have any trouble from them but I figured it’s only right to let you know that. …