Set ROI Command not supported, why?


I purchased a APM based quadcopter after watching youtube videos of auto pilot and especially a camera following a region of interest (ROI). I want to video my land on a monthly basis going over the same route each time with the camera concentrated on certain points.

In Mission Planner 1.2.95 Set ROI now says “Command not supported”

Thanks for a great program but can i cask why it was removed and when or if it will be supported?

The proper command is DO_SET_ROI … nd-events/

Hi Craig

The solved flag you added is not correct as this is not solved at all as far as i can see

Others are asking the same question so obviously there is confusion.


DO_SET_ROI is no longer in the waypoint drop down list so can you please explain how we can use it

ROI was shown as a red waypoint marker that the camera would point at, and as such in the videos i have seen works very well. If you right click on the map there is still a Set ROI available but if you select it it says not supported,

Any explanation would help


do set roi is only supported by copter.

My copter is currently being built, they are waiting for the transmitter to arrive before shipping so at this time I cant connect it

I only have Mission Planner installed

Do i have to have my apm connected to see DO_SET_ROI?

Some sort of instructions would be really helpful and if I knew what to do I would write them to help others as this seems to be a regular question


do set roi appears when you are connected to a arducopter.

Thanks for clearing this up.

IMO it would be better to allow users to setup a mission without being connected but thats just my opinion

MP remebers what you where last connected to. so if the last thing connected was a arducopter, and you closed and opened MP, then roi would be in the list.