Servers by jDrones

Set param error

I am using Mission Planner 1.3.37 and I am trying to go thru the mandatory hardware calibrations. when I get to the ESC calibration I get the following error message:
"Set param error. Please ensure your version is AC3.3+"
I am trying to set up a hexacopter
my equipment is the following
ardupilot ver 2.8
taranis x9dplus
x8r
anyone know how to fix this?

@tradert55,
ArduCopter v3.3 may not run on the APM2.x due to memory limitations.
Regards,
TCIII GM

I am really new to this and maybe i am misunderstanding but I am using Mission Planer 1.3.37

is this the same thing as AC3.3+ ?

@tradert55,
AC3.3+ is the version of the ArduCopter firmware that you are trying to run on your APM2.8.
Mission Planner is the Ground Control Station.

totally frustrated at this point. first I can get the apm to arm then I cant, checked all parameters that would keep it from arming and they seem to be fine (arming in stabilize mode), then when I did the ESC calibration motors 1thru 4 ran fine but 5 and 6 would not start. So i calibrated 5 and 6 manually now they run but 1 thru 4 wont. Ive uninstalled mission planner and replaced it with earlier versions but that doesnt help either. when i install firmware, ac3.3.3 seems to install fine but mission planner shows the error listed at the start of this thread when i try to do the esc calibration built into mission planner. I have checked and rechecked all wire connections, Ive started new models in my x9d plus so that if there is something i have missed it shouldnt be a factor but still no joy. Does anyone have a clue what im doing wrong? going bald very quickly.

Are you using a Pixhawk or Ardupilot FC? As was stated earlier, Ardupilot cannot run anything above 3.2.1 firmware.

well i am not sure what is actually installing on my board but i suspect it is a later version than 3.3. I did the option where it says to pick previous version of the firmware, but when i continue it tells me that version is no longer available and that it is updating to the latest version and I no longer get the set param error. I would do the custom install but i have looked all over the internet for something like 3.2.1 or earlier but havent been able to find it. when i get to the point where I try to arm the model i now get this error message; "PREARM: RC NOT CALIBRATED’

You didn’t completely answer the question. Are you using a PX4/Pixhawk or an Ardupilot FC?

Prearm: RC not calibrated is exactly how it sounds. You need to calibrate your RC transmitter before you can fly.

i have the same issue
am using the mission planner latest version
when i get to calibrate esc i get that message
"Set param error. Please ensure your version is AC3.3+"
i am using clone Arducopter 2.8
the radio is calibrated and i see the parameters change when i move the throttle and elevator sticks

please help

Yea if this could be answered that would be great because this software should be sufficient for use like it is told to us.

The answer is that if you are running an APM (not a Pixhawk) then you will not be able to load 3.3.x firmware onto it. No matter how hard you try. Nobody in this thread has indicated for sure if they have a PIxhawk or not. This is a known restriction of staying with the APM hardware over the Pixhawk hardware.

do wich firm ware should i load for apm 2.8

If it’s an APM and not a Pixhawk then the highest version of Ardupilot you will be able to load is 3.2.1.

hi you have a link to the download/
is that thefirm ware i upload to the FC?
and what planner would i use
thanks for you help

Using APM Planner it should auto detect the board version as an Arduino Mega 2560 and install version 3.2.1 of the firmware for you.
You can also download the firmware to have on your PC to use the “load custom firmware” button at this location APM 2.5 archive

If you are hitting a limitation with the ESC calibration in your GCS you can do it the manual way, which I find easier.

  1. Tx switched on - throttle high
  2. Power up FC and Rx and wait for the initialisation to finish.
  3. Power the FC and Rx down.
  4. Power up the FC and Rx again, and wait for the ESC to sound their programming beeps.
  5. Move throttle on Tx to low and ESC should be calibrated.
  6. Power everything off and you are done.

i did this and the props spin when i arm?
how do i change that as the spin when armed option is greyed out?

The parameter for Motor Spin Armed

Go to the parameter list and change it there.

I have the same issue. But im using pixhawk… Did u know why?

Servers by jDrones