Set flight modes for turnigy 9x

My configuration:
rover using 2 power chair motors with sabertooth 2x25 controller.
APM 2.5 with power module. internal compass on board. GPS on plastic standoffs.
rover code 2.45 loaded on APM.
Turnigy 9x with frksky module and 8xr receiver.
I can drive in manual position.Forward,back,left and right.
I cannot get flight modes to work except for manual mode.
receiver connections are as follows:
rec 1 to apm 1
rec 2 to apm 3
rec 5 to apm 8
Very confused,A little help would be appreciated.


You need the following minimum transmitter/receiver channels:

One channel for steering (aileron joystick channel)

One channel for throttle (elevator joystick channel)

One channel for waypoint recording (usually gear switch channel)

One channel for mode selection (usually the flap switch (must be three position) channel)

In the MP Full Parameter List I have set up the following RCMAP

RCMAP_PITCH channel 3 (not used)

RCMAP_ROLL channel 1 (aileron) steering

RCMAP_ THRO channel 2 (elevator) throttle

RCMAP_YAW channel 4 (not used)

MODE_CH for selecting modes of operation

LEARN_CH for designating a waypoint when in the Learning Mode

Your Flight Modes should read from top to bottom: Auto, Auto, Learning, Learning, Manual, Manual.

Have you read through the APM:Rover Wiki:

TCIII ArduRover2 Developer

I followed your advise and got the flight modes working with turnigy9x with er9x firmware.
Now I cannot get gps to lock.I even sucessfully upgraded firmware for ublox gps module.I have a internal compass in the apm 2.5. Just keep getting no gps fix on mp screen.