Servos set to SERVOn_MIN, not _TRIM on power up

I’m having a real hard time here, guys. I hope you can correct what must be my misunderstanding. Situation - conventional tractor plane with ailerons, elevator, throttle and rudder. Flying fine with Pixhawk manufactured by 3DR using ArduPlane 3.7.1. Mission Planner 1.3.49. Changed to ArduPlane 3.8.0. I power up. Flight control surfaces are all askew. All SERVOn_TRIM values set to equal SERVOn_MIN. I write 1500 to all SERVOn_TRIM. Do REFRESH PARAMETERS. All trim values = 1500. Power off/on. All trim values have reverted to the servo minimum (1050). I have set all auto trimming parameters to disable.

  1. I must be under a misconception concerning the SERVOn_TRIM parameter?
  2. How can I flash 3.7.1 firmware?
  3. How can I reflash 3.8.0 firmware?


1 Like

set TRIM_RC_AT_START to 0 to fix it
sorry about this, its a bug

Hi Tridge, Thank you for the quick response. I had already tried that - no joy. I have discovered that the problem is related to the PPM input from the RC receiver. If I unplug my RC receiver and cycle power, the servo trim values are retained. I have added a 2 second delay from power up to when the receiver begins sending PPM data. That seems to have solved the problem.

are you sure the problem happens with TRIM_RC_AT_START=0 ?

Yes, I had done this before posting original query. I searched through all parameters related to servo and and disabled each.