Servos only respond to throttle only in RC3IN, not Motor(1-4)

I’m looking for help with this because I have an issue with my 450mm quadcopter. My best attempts at explaining this issue to Google have fallen well short of effective.

I’m using the following system components:
FC: Pixhawk 2.4.8 with fmuv3 firmware
RX: RadioLink R12DS with PRM-03 OSD Telemetry Module
TX: RadioLink AT10II
GPS/Compass: Readytosky M8N GPS/Compass Module
ESCs: QWinOut 40A Brushless Simonk firmware
Motors: QWinOut 1000KV Brushless
RX connected to FC via SBUS to RCIN.

Everything is working, it would seem, except the transmitter only drives the servos with SERVOx_FUNCTION is set to RC3IN, and in that case, only the throttle responds, and motors 1 and 3 (front left and front right) spin immediately, and the rear two motors only start spinning at about 50% throttle. Roll, pitch, and yaw are unresponsive.

When SERVOx_FUNCTION is set to Motor(1-4), there is no output to the servos. Nothing happens.

I am zero percent sure what parameters you might need to give me some tips or help, but let me know and I’ll provide ASAP. I have an experiment I’m trying to run with this drone.

Post the parameter file.

ParameterTroubleshootingTaysom.param (17.3 KB)

Have you tried to use mission planner’s motor test function? You may need to adjust the MOT_SPIN_MIN and the MOT_SPIN_ARM. They are still at defaults and if the motors aren’t turning that may need to be bumped up a bit. Using the motor test will help you figure that out.

Controlling the motors using the RCxIN will end badly, so don’t do that.

Playing with those settings and re-calibrating the ESCs, Mission Planner can now consistently run the motors in the motor test, but the RC transmitter is still not registering that when I move the throttle or left/right stick, the motors should respond accordingly. The motors still only show output when attached to RC3IN (I didn’t put it back; I’m just pointing out that it’s the last time they were driven by the transmitter).

Interestingly, I’m not sure the transmitter is assigning the left stick to the throttle function or either stick to the flight control functions. Here’s what I see in my transmitter as well as in Mission Planner and a couple shots of the wiring of my RX and FC.

Do the correct Green bars move when the respective sticks are moved? Radio configured for AETR? No mixing configured on the radio?

1 Like

Alright, now we’re getting out of my depth. I’m not sure what you mean by those things, but when I move the left stick up and down, the servo output stays at 1000. When I move them to calibrate the radio, the bars move as needed.

Now that that’s handled, what do you mean by AETR and mixing? Where might I see those settings?

You are testing the motors using no props, right?

And the vehicle is tied down on the desk right?

Yes. I’ve done testing with props, but for this part of the testing, I don’t have them installed.

You are testing in which flight mode?
Loiter? Alt hold?

Stabilize was the default, so I left it there. I can’t break it if I don’t change it without guidance. LOL

Ok. Then the tests are invalid and only produce confused results. You are testing a closed loop in an open loop fashion. It will simply not behave like you expect.

Just use the mission planner motor test and forget about any other form of motor testing.

This is also explained in the methodic tuning Blog post.

I’m trying to make the RC transmitter I have do its job. Mission Planner already controls the motors; I need to be ale to now.

The RC receiver test and calibration does that job.

The MP motor test, tests the output.

Those are the only two tests that you need

1 Like

And it’s still not working, which is what brings me to this board. To see if anyone can offer suggestions as to what might be going wrong and what I can do to make that not happen this way.

Somewhere, the RC transmitter sticks are assigned to a specific set of servo operations. Those seem to be missing, so when I move the calibrated stick to the calibrate motors/ESCs, nothing happens because the motors don’t seem to know that they’re being spoken to. If that makes any sense. I need to find THOSE parameters.

Sorry, it still is not clear. Can you elaborate?

I have the feeling that you are trying to fix a non existing problem. Did you follow the steps on the ArduPilot Methodic Configurator software?

You are not supposed to manually change the servox_function parameters. Doing so causes strange effects

1 Like

I’ll bring the setup outside and run it up and post a video showing what isn’t happening when it should be.

When I push the throttle up, nothing happens. There is no motion on the servos when they are set to the Motors. They do not adjust spin rate to cause yaw, pitch, or roll movements, either.

When I set the servos to RC3IN, they move when I advance the throttle, but do not adjust spin rates to cause yaw, pitch, or roll movements. They only collectively spin faster or slower.

What this means is that the RC transmitter’s channel assignments are wrong, or the FC is not communicating with the proper Main Out channels. I need to figure out how to reset the channel assignments so that the FC drives the right servos. I just don’t know how.

I assumed I wouldn’t have to do this much tweaking, but since I do, I’m just looking for a little insight.

Thanks so far for all the help. It’s getting me on the right track, I’m just not quite there yet.

Probably a stupid question but it wasn’t mentioned yet.
You did arm your drone before trying to fly, right?
Do you have a safety switch installed? If yes, did you press it before the test?

Also picking up one of Daves questions again, when you are in the RC calibration screen, do the correct green bars move in the correct direction when you move the sticks and switches in you RC transmitter?

AETR stand for Aileron-Elevator-Throttle-Rudder, which is the default order for RC channel 1 to 4.

1 Like

I did press the Safety Switch and the servos sing to me to let me know they like it. LOL Even Mission Planner shows that it is armed and ready to fly.

The problem seems to be with the AETR settings. As you can see in my AUX-CH image, those don’t appear to be attached to those channels as they should be, and I don’t know why. AETR is the order for the other menus that adjust channel operation, but somehow, this isn’t happening for my drone.