Servos not responding to Radio input

Hi guys! firstly, I just want to say that I’ve been following this project for a LOOOONGGG time, but of course, life gets in the way of personal hobbies/projects. I’m finally getting back to my hobbies and I decided to start with APM 2.6 on a rover before getting up in the air again since that gets a little more complex.

Anyhow, I’ve got a problem as my title suggests that I’ve been working through all weekend…Cant seem to find any resolution.

My servos arent responding to my radio inputs… I know the APM registers the I/Os since when I’m connected via USB I can calibrate and see the outputs. Once I disconnect, hook up the battery, and try to get it going, no go.

Regarding the flight modes, I’ve tried them all. I dont seem to see any arming options. So I’m sticking to Auto and Manual mode to troubleshoot this problem. If it matters at all, I’m using an older futuba skysport 6 72 Mhz radio with a Rx that requires power to function as well. I tried supplying power to the receiver first, then I also tried powering through the power module. the JP1 pins are disconnected.

I need help to get this going! :frowning:

If you have jumper J1 removed in the APM, you need to have a BEC attached to the APM servo output bus to power the servos that you have attached to the APM.

It sounds like it may just be easier to jumper the pins, no?

adding a BEC circuit sounds like additional weight. Also, I have the v1.0 Power Module hooked up for the motor drive power to the ESC and the motor isnt being driven either. Thats why I’m baffled.

In reading this: … your_board my setup matches section 6.0

this is the power module I’m using:

I was under the impression that this distributed enough power from the battery to power the APM controller and any additional servos plugged into the output. Do you have a link to a suggested BEC anywhere? I wouldn’t mind seeing what others are using.

Thanks for the prompt response!

I do not recommend using the Power Module to power the servo bus as you can easily trip the internal thermal fuse in the APM if J1 is installed. The Power Module is really sized to power just the APM, GPS/Compass, Telemetry Radio, and some other small current loads, but not the servos.
Here is a quote from the Wiki link:
"If servos are used, supplementary power is required. Generally one power supply is provided for the board and one or more additional power supplies for the servos. But if a sufficiently large external BEC is used it can supply power for both via the OUTPUT connector."
However the choice is yours not to use a BEC to power the servo output bus. Good luck.

ok, I understand what you mean now. I’ll try this out tonight and report back. I should have enough hardware to make this happen.

I’ll basically supply power to the Servo & ESC externally, and only use +/- to grab power from a 5V supply

I’ll report back.

I just thought of something. I have a 5V battery with a red/black wire in a servo connector for my receiver. Cant I plug that into one of the output ports to distribute 5V to the output rail? This way the steering servo would have 5V to run off of and the ESC would have the same.

Yes, you can use a 5 vdc battery to power the servo output power bus, but make sure that you have jumper J1 removed inside the APM.

Ok, I kind of feel silly. You wont believe it. I was plugging in the 5V battery into the Input plugs the whole time yesterday!!! Who knew I would be so tired after doing renos at my house to work on this.

I got home after work today and installed the battery to the output rail, and there you have it! It works!

Now I just need the camera to show up so I can get my OSD data to display and see whats really going on.

Thanks for your help TCIII!