Servers by jDrones

Servos move on power-up

When I power up the aircraft, the servos move to one side, almost to the stop.

It is only after the Pi/Navio2/ArduPlane 3.7 system comes up that the servos move back to center.

Is there a way to stop that behavior?

Thanks,

Paul

Can you provide more detail?

  1. When you “Power Up” the aircraft by connecting the main battery, the Safety Switch (a blinking red button) should prevent the servos from moving, until you press and hold it for several seconds.

  2. Are you saying that after you press-and-hold the safety switch, the servos deflect to maximums? In that case, what mode are you in when you press-and-hold the safety switch?

Thanks hunt0r.

I am using a Navio2 so there is no safety switch that I know of.

Yes, as soon as I plug in the main battery the servos all move to one side, but fortunately not to the stops. When the ArduPlane initializes about 20 seconds later, the servos go back to center.

Paul

Just thought of something - in addition to have a standard power module to provide 5v power to the Navio2, I also have a second 5v regulator that powers the servo rail. It turns on immediately when the main battery is connected, so until the Navio2 and ArduPlane come up, the servos get power, but no control signal.

Sorry, I misunderstood your first post. I don’t have any experience with a Navio2, so I’ll defer to someone who has used that autopilot.

I use Pixhawk and it does the same, doesn’t matter if one or two power supplies. IIRC the elevator moves down by design, the other servos you can stop moving on a PH by setting BRD_SAFETY_MASK to zero for the channels that shouldn’t move until you press safety switch, i.e. BRD_SAFETY_MASK=16352 for no movement for ch1 to ch5 (use calculatur in programmer mode to translate bin to decimal).

Markus,

Thanks for the tips. It appears that the BRD_SAFETY_MASK is not used in the Navio2 implementation.
Yes, the elevator goes down in the Navio2 system as well.

Paul

Did you ever resolve this issue?
I’ve got the same issue with PixHawk 1.
BRD_SAFETY_MASK makes no difference.
Transmitter on or off at power up makes no difference.

Jeff,

Regrettably I have never used the safety switch and therefore have no experience nor advice to offer. Since in my case the servos do not move the stops, I just lived with the behavior.

I have a push button that came with my Pixhawk so I will give that a try on the bench with my setup and see if the “servo movements on power-up” can be avoided.

I suppose if we could turn on the power to the servo rail separately and after the Pixhawk boots up then that may work. But that of course means adding another connection and or switch.

Paul

Thanks Paul,
The plan is to add a separate switch for the servo power, but I was hoping someone had found a magic bit to set.

Servers by jDrones