Servos do not response at all, after every software restart

Hello to all of you!
I’m new here and this is my first post. I hope and wish under your support, to found a solution to my strange issue!
So, first to say that I’m not very familiar with mission planner 1.3.46 and APM2.8 for traditional heli 450 electric. and i was totally lost in many steps during the whole procedure and setup.
Fortunately, after a lot of readings Plus wrong and correct attempts, …finally i succeed to setup my heli …till the step to move my swash and servos correctly according the green bars in the software. And here it starts my issue. After lets say around 3 or 4 (heli and software) restarts, all of my servos are not moving at all. Not even a noisy sound by them or anything!! they are completely …dead! Of course i test servos directly in RX and all are working very well. Another strange thing is that whenever i move my TX sticks the green bars are following correctly my moves But servos are off!!! M.P. software gives me the error ‘RC not calibrated’ I re-do calibration lots of times but …nothing!!! Same results as described!!! The only thing i can Note, is that my PWM values for each green bar as i move my sticks, are above than the established or recommended ones. I don’t know if this has anything to do!!!
So, I’m stuck here and kindly ask any of you for your efforts and your help to continue with the rest !!! i use futaba T8FG Super as TX
Many thanks in advance :slight_smile:

Please tell me what version of ArduCopter was loaded to your APM2.8. To find out, connect to your heli in mission planner and in the Flight Data screen there is a set of tabs below the HUD. Go to the message tab and read the ArduCopter version. I think the APM is limited to ArduCopter 3.2.1. Also please upload a param file.

Bnsgeyer, Thanks a lot for your reply!
So as soon I will be at home, I will answer you back to your requests! But before that, I realize something new to my issue. Every time I disconnect software from pc and heli from battery and then I reconnect them, i find out, that in full parameter list two parameters are changing theire values by themselves. RC3_MIN and RC3_MAX. are far above the recommended values, and when I enter the correct one (1100 and 1900) immediately the swash tilt and after a radio calibration everything works as it should plus motor arming! And when I disconnect and reconnect everything …same issue again till I change the values.
I don’t know if it means something for you …but me …I’m really lost.
Any assistance will be MUCH APPRECIATED!!!

Ok so, dear bnsgeyer Bill Geyer the version of Arducopter i use is 3.2.1 (36b405fb) and i will attach the parameter file without changing BY ME the values of RC3_MIN and RC3_MAX. But When i put manually the correct values …all works normally (servos, Arming, Swash and Green bars in software)Parameter File.param (5.4 KB)

Ok. So I have some experience with APM2.8. We ran into some issues using the latest version of mission planner. I suggest you go into the Ardupilot website and download mission planner 1.3.37. We found it to work better with AC3.2.1. I’m not sure if this will solve you problem but I know you will have issues if you continue to use the latest version of MIssion planner

Thank you for your advise!! I will follow your recommendation to see if will change something !! Thanks once again for your effort

Friend bnsgeyer, finally I try version 1.3.37 but unfortunately nothing change!! Same results!! If their is any other advise …please, just let me know!!
I believe has something to do with my tx end points in conjunction with mission planner pwm values but I can’t realize it.
Anyway …will see

I use futaba as well for my tx. What type of model are you using in the tx? Acro or heli? Acro is an airplane setup and that is what I use for my heli with a pixhawk. Is your heli electric powered or nitro?

What receiver are you using and how are the channels mapped from the receiver to the APM?

Ok! in my TX I’m using Acro mode and to be more specific Type: Airplane, Wing: Normal 1AIL, Tail: Normal.
My heli is class 450 electric
My RX is 8 channels model: R6208SB
The channels mapping from RX to APM are as follow
ch1 to ch1 AIL
ch2 to ch2 ELE
ch3 to ch8 THR
ch4 to ch4 RUD
ch5 to ch5 AUX1
ch6 to ch3 PIT
ch7 to ch6 AUX2
ch8 to ch7 AUX3

In TX i reversed THR (ch3) and VPP (ch6)
Appreciate your assistant :wink:

I think you really want to just map the channels straight through from the RX to APM
Thus, The channels mapping from RX to APM are as follow
ch1 to ch1 AIL
ch2 to ch2 ELE
ch3 to ch3 Collective coming straight from what is throttle on tx
ch4 to ch4 RUD
ch5 to ch5 Gear - this is really flight mode
ch6 to ch6 AUX1
ch7 to ch7 AUX2
ch8 to ch8 AUX3 - this will be your ESC governor - Look up RSC in Trad Heli wiki

Hopefully this helps

Hi Bill. Can you please be a bit more clear, on what exactly you mean, for ch3 and ch8? Can you please explain a bit more in details, for those two channels? To clarify …my ESC, do not use governor mode, so that’s because I’m using RSC mode 1

Be well …Dim

A! and something more I forget to mention: The way I cable rx to apm, is the recommended way, described on arduwiki for a traditional heli. I didn’t found somewhere, someone to describe, the way you suggest to me. And if finally I will try your way, How to connect on APM output, my servos, my throttle, my esc and what RSC mode to use then? That’s why I’m asking you to give some more details, especially for ch3 (thr), ch6 (pit) and ch8 motor or esc or …I don’t know I’m confused !!
Thanks again dear friend :slight_smile:

I will have to go back and look at my notes when I set up my heli with AC 3.2.1. I seemed to remember the set up that you showed my but couldn’t remember why I did it that way. I even had a esc with govenor mode. I would recommend keeping the way you had it. I may have used the heli setup in the Tx and used the throttle curve features of the radio to run the esc.
I’m sorry I don’t have better answers. I still am not sure why you are having this problem

In any case, I would like to THANK YOU so much for your effort and your trying to help me!!
Really appreciate it :slight_smile:

Try setting the following parameters manually and see if that helps


Read the “Rotor Speed Control (RSC) using Output Channel 8 on APM2.5” section on this page
Channel 8 set up for APM

Also look at the “Rotor Speed Control (RSC) using Output Channel 8 on APM2.5” section on this page

details of RSC mode setup

It says that Channel 8 has to be within 10 PWM of RC8_MIN. So check on the status page of the flight data tab of mission planner. There are many parameters that are listed. Look at the RCIN 8 parameter and with your collective low make sure the PWM is reading 1100 +/- 10. Hopefully this helps solve the servo response issue.

This setup will be very complicated. How familiar are you with setting up a helicopter without an APM and just using the features of the tx?
I’d recommend setting up the heli without the APM first then moving from the tx set up to the APM. It would be easier as you already have the throttle curves figured out. if you keep your collective curve linear from 0 to 100 with 0 around -3 deg pitch and 100 around 12 deg pitch, that would help with moving to the APM.
Just my thoughts on your situation.

Dear Bill, first to clarify that my rc heli setup knowledge level, (mechanically and flight controllers features) are …let’s say, above middle level. Means that I was doing well in the past, with other controllers.
But for apm I have a basic question, before to continue with your advises. Maybe is an annoying question, (sorry if it is), but it’s not clear for me at the moment. You say to me, it’s better to do firstly a manually mechanical setup , and then to continue with apm setup! Very clear and I thought about this as well. But how to do this? I mean, how to bypass temporary apm?? Should I go to heli setup page on mission planner and press the manual option? Is this the way to bypass apm? And after that (when I finish mechanical), to go back there and press active, to continue with apm? Or maybe this is not the correct way and I have to move differently?
Thanks for your help!

I meant to connect the servos directly to the receiver and set up the helicopter using your transmitter and receiver and a 3 axis gyro. That way you have a good throttle curve based on a linear collective curve setup. Otherwise you will have to learn not only the APM setup but your throttle curve too. Have you flown this helicopter before with just a 3 axis gyro and receiver (no APM)?

Ah …ok! you meant not bypass, but APM to be not connected at all ! Alright, Clear. Just RX, TX, and a Gyro.
Like my Align 250, which i use just only a tail gyro (Spartan) and flies very well.
Thanks Bill.