Servo7_function=39 not working in VTOL

so as per the document at https://ardupilot.org/plane/docs/guide-tilt-rotor.html

i have setup a non vectored yaw VTOL using Arduplane in the Y3 config.

as per the setup i have assigned Servo7_Function - 39

so i can control the Yaw servo in Quad mode using the rear servo.

somehow the rear servo does not respond to the Rudder stick of the transmitter when in QHover mode or QStabilize mode.

but when i switch to FBWA mode the rudder stick responds to Servo4_Function - 21 which is the Plane rudder.

am i missing something or am i going complete offtrack with my settings??

attaching the setup “parameter” file to this post

:slight_smile:

VTOL_NON_VECTORED_15_Jan_2021.param (20.5 KB)

Hi,

Yes, this setting is correct.

Yes, this is true. In the Q-modes, the rear servo is driven by the flight controller so you won’t see any movement until you are hovering. If the plane wants to spin then set SERVO7_REVERSED to 1.

You may or may not see any movement if you turn the plane back and forth. I can’t remember. Your C7 output should look something like this below from my FireFLY3 tricopter VTOL.

Good luck!

1 Like

oh! wow…

so that means i cannot test the Rear Servo Yaw movement till the aircraft takes to air??

strange! because it will always be better to check all the servos as a pre-flight requirement!

i might be wrong but that condition is difficult to digest! :slight_smile:

how can i achieve the Yaw movement during QHover or QLoiter if the rear Yaw servo cannot be moved manually.

-Sid

You can probably remove the props and ground test it while armed in a Q-mode and see if the rear motor tilts to one side. I typically test it “live” with the props on during a short hover in QSTABILIZE mode. Either the plane starts rotating one direction or the tail is steady or wags back and forth. If the plane rotates constantly, reverse SERVO7. If it wags too much, start tuning. Sometimes all you need to tweek is Q_A_RAT_YAW_P.

Good luck!

1 Like

oh!

frankly i had some bad experiences with tri-copter flights previously… so a bit wary when trying with VTOL

but still i see it strange that the Rear Servo Yaw won’t move when on ground.

thanks Greg for those inputs! :slight_smile:

You will be fine if you try a simple test in QSTABILIZE mode on grass or another softer surface like dirt. Just give it enough throttle to get off the ground a few feet and be ready to drop the throttle if something goes wrong.

You can certainly test the transmitter stick control on the ground while armed similar to what we did when building our own quadcopters. Move the right stick (Mode 2) backward and the front motors should spin faster. Move the right stick to the right and the left front motor should move faster.

Here is my FireFLY6 converted to a FireFLY3 tricopter VTOL.

1 Like

hi greg… as per your explanation…

“You can certainly test the transmitter stick control on the ground while armed similar to what we did when building our own quadcopters. Move the right stick (Mode 1) backward and the front motors should spin faster. Move the right stick to the right and the left front motor should move faster”

i will be using Mode 2

is this not the Vectored_Yaw format?

Ooops, my bad! Mode 2 is correct.

The reason Q-Yaw was disabled ‘on the ground’ in stable 4.0.x is because low throttle yaw can be used to ARM the aircraft. Which could result in Aircraft/prop damage or inadvertent arming when conducting a Q-Yaw test. It is an option in 4.1.0dev, and not likely to be added to 4.1.x stable for the above reasons. I actually grounded my Nimbus thinking this was a firmware fault! But after talking Tridge totally get why it is best left as part of the Q hover checks when in the air.