Servo travel bigger than in Manual Mode! (ELEVON TX MIXING)

Hi guys. Don’t know where to post but here.
I have a problem with servo throw in TX elevon mode.

I followed this instruction to setup elevon mixing in transmitter first both manual and other mode. … evon-mode/

[quote]To select elevon mode or reverse elevon channels, use the elevon checkboxes at the bottom:

Roll to the right illustrated below.

It takes a little trial-and-error to set up elevons on any particular aircraft, but here are the basic steps:

First, set it up in manual mode by setting up elevon mixing on your RC transmitter. bla bla… an so on as shown on the link

So, Firstly. I setup manually the servo throw using only receiver without the board. All went well working. Servo throw went to whatever they should be.

Then, I plug everything on my Flying Wing. Everything went well on Manual Mode. So i switched to FBWA mode to see the behavior of the elevon, the behavior seems good. They move to the desired position when I pitch or roll the plane.

However (here is the problem), when I ROLL it to the Maximum roll. The servo goes to beyond the limit I have set on the manual mode! You know, it will broke the hinges or any mechanism on it, right?

What I have tried: I went to Advance Parameter. Search for RC1_MIN (also max and rc2) change it to the same as the min/max value on manual mode I’ve seen on “Status” on mission planer. (ch1out/ch2out). But nothing changed.

I also change value on the MIXING_GAIN. Not working also (as this trick work on ELEVON_OUTPUT)

Anyone can help me? Or any more advanced forum should i visit? (I don’t think so) Thanks before.
Sorry, English is not my first language.

Controller: Pixhawk (Fixhawk RcTimer)
Firmware: ArduPlane v3.1.1
Airframe: Flying Wing (new style elevon mix on Transmitter)

Not sure if this is exactly your problem, but I found great success switching to the newer Elevon Output mode, which is now the recommended elevon setup:

viewtopic.php?f=102&t=9532 … PUT_option

Hope you can solve your problem!