Servo pulse width

I am working on a traditional helicopter with 4 servos. One servo is the HBL 880 tail servo ( It has a central pulse width of 760us.

I am having issues using it with the pixhawk and arducopter 3.5.5. I believe my issue is that I cannot set my max, min and trim values low enough to control the full range of the servo. I am limited to a lower value of 800.

Is there any way around this? Is it possible to change the limits within mission planner to allow for lower pulse widths? Or do I need to find a new servo for this?

It will work fine with AC3.5.5. If your ground station won’t let you set it use a different ground station like QGroundControl which I know lets you set it for the 760uS servos. Because I’m flying a couple of those on my helicopters.

We were talking the other day about updating the allowed range for heli. I will try to get this done for 3.6.

I just fixed this. The change will come out in the next major release (Copter 3.6).

Aha! Perfect! Works no problem on QGroundControl - I just had to override the limits warning.

It will also let you keep the setting if I move back to mission planner.

Thanks for the help Chris! Glad to see the limits will be increased for the future release. :slight_smile:


Worth noting that Mission Planner will allow you to set any value if you use the full parameter list or full parameter tree. Its restrictions only apply to the config and tuning pages.