Servo output not reading throttle(not working)

Happy new year!
Hi, so i´m a newbie using a pixhawk 2.4.8 for a proyect. I installed rover 4.0, did all the initial setup and everything was working fine. I was using the separate steering and throttle configuration with no issues. Ground steering on servo 1 (main out port 1) and Throttle on servo 3 (main out port 3). I used a single motor and esc vehicule to test everything. However, the rover for the project requires 6 motors and 6 esc and is a “skid steering” like vehicle. So i proceeded to change the motor and servo configuration. I connected all 6 esc´s to the main out ports from 2 to 7. After disabling main out 1, for the three motors on the left, i selected “Throttle Left” and for those on the right side, i selected “Throttle Right”. When i was going to test it (after arming the vehicle), 1 motor from one side and two from the other side started spinning with no throttle on the transmitter. Didn´t work. Then i tried using “Motor 1” “Motor 2”, …, etc and didn´t work as well, some motors spinned, others didn´t. I decided to leave everything that way and try to fix it the next day (today). So when i turned on everything to keep testing, i got no throttle. As soon as i arm the vehicule, some motors start beeping slowly, which according to the manual, means that the throttle signal is abnormal. I disconnected all the esc´s and left just one on servo 3 and connected a servo on servo 1, changing its values back to “Throttle” and “GroundSteering”, respectively. Tested it and also got no Throttle, servo does work. Then, i tested every single esc and motor, connecting them directly to the receiver (no pixhawk), and all of them worked, so they are not faulty after all of that. As i kept testing on Mission planner, i noticed that, In Servo output, Throttle signal stayed at 1500(trim value), no matter if i moved the Throttle stick. It only changes according to the value i change on “trim”. However, Ground steering signal was detected as i moved the yaw stick. Also, in radio calibration, as i moved all the sticks, every movement was detected.
How can i fix this? Can i reinstall the firmware and do the configuration all over again to get the throttle working, at least with the trottle and groundsteering configuration?
Since i clearly messed up, how should i configure the servo output to get it working with the 6 motors?
Thanks in advance!

1 Like

Any luck finding a solution? I also have this problem.

1 Like

Dear everyone

I got similar problem on the ardurover4.0 with navio2 and mission planner as GCS.

I connected a steering motor to servo output1 as “GroundSteering.” It is connected to “RCIN1” and “GroundSteering” simultaneously and implicitly. Then, I can control the servo1 from channel1 of RCpropo and motor test both.

But when I connected an ESC motor to servo3 as “Throttle.”, it is not connected to “RCIN3.” So I can not control the ESC motor from RCpropo, but it works from the motor test. On the other hand, when I changed the Servo output3 settings to “RCIN3” directly instead of “Throttle”, I can control the ESC motor from RCpropo’s channel3 correctly, but the MotorTest doesn’t work.

I think there is a software problem on the internal connection of “Throttle” and “RCIN3.”

Does anyone have a solution for this problem?



Hi guys,
are you fix it?

For me, using the pixhawk for the first time not in “RCPassThru” or “Manual” mode, I had to learn that there are two steps to making the pixhawk control motors … arm, and separately, safety switch. I had armed, but not tripped the safety switch (Button on my gps). The word “Safety” kept flashing in mission planner, but I thought that was just good life advice :-).