Servo output jumping around?

Hi all

1st rover so quite probably doing something wrong but lost…

It’s set up to skid steering, everything calibrates fine, motors spin so ESC good etc. Radio appears correctly configured in that on Radio calibration pg in MP with a Mode 2 Taranis Pitch/Roll/Yaw/Throttle all correspond to the same in the Radio calibration page. (exactly like i’d expect on a quad)

But in Servo Outputs page with
Servo1=Throttle Left
Servo3=Throttel right

The outputs don’t correspond to Radio commands given at all. Instead 3 seems to randomly jump between PWM 250 and 1500 and 1 is stuck on 250

Sorry not sure how to add an image but this link might work to screenshot

Attached my param file, Rover1.param (10.7 KB)

Any pointers to my silly mistake welcome thanks!

Hi Jane,

What kind of ESC is being used on the vehicle? I see that the MOT_PWM_TYPE is set to “4” (BrushedBiPolar) which is a bit unusual. It’s possible your vehicle really does use this kind of output but “0” (Normal ESC with PWM range from 1000 ~ 2000) is much more common.

By the way, have you tried the MP’s motor output test?

Hi

Thanks, ja the test motor just pops up “Command denied by Autopilot”… Any idea what that’s about?

“ESC” is a TB6612 but motors are spinning fine in correlation to Servo outputs - i.e when connected to Servo3 (1500PWM) spins fast and connected to Servo1 (250) doesn’t move

jane

Jane,

Ah, the vehicle is probably armed. I think it rejects the motor test command when the vehicle is armed.

There’s some info on arming/disarming on the wiki. Some users disable arming/disarming the vehicle by setting the ARMING_REQUIRE parameter to zero. I’m not a fan of this but it’s possible. To use the motor test you’ll likely need to set ARMING_REQUIRE = 1, reboot the autopilot board and try the motor test again.

1 Like

Any one else have any ideas?

Still think it’s some simple thing I have wrong, it’s not the ESC/motors but higher up the chain - I know this because the servo output isn’t behaving sensically.

So dud PH or more likely bad config, perhaps broken somewhere between the radio and the PH?

Again: on radio calibration page all switches behave as expected: Th=TH, Roll=Roll etc - I get the visual feed back I expect on this page.

But: on servo out page - I get no correlation to radio inputs whatsoever. Even just trying to set a random servo to output the Throttle - zero response.

The above is true when armed or when setting ARMING_Required on or off

And only sign of something being off/wrong I can find is that I can’t get the motor test to go: “Command denied by autopilot” also get this when ARMING_Required set both off anf on and even when set and system arms successfully

Have also tried non-std servo outs but same problems

Thought maybe I had some grounding issue but have added multiple grounds between all components, no change

I’m really stumped :?

Still trying if anyone has ideas…

With everything configured as default, Radio calibrated, and all inputs on radio doing exactly as expected in mission planner on radio cal screen. I can ONLY get a response in MP Servo Output screen on whichever servo I set to be GroundSteering (which then responds to a combo of Th and Roll)

I’ve tried every combos of rc map/options/Taranis setup, selections possible (literally) But I know the Radio>Reciever>PH pipeline isn’t broken as Radio Cal screen visualises everything perfectly…(and I fly other things with same radio)/ So there must be a config I’m missing?!?/Other debug suggestions?

RCMAP_PITCH = 2
RCMAP_ROLL = 1
RCMAP_THROTTLE = 3
RCMAP_YAW = 4
SERVO1_FUNCTION = 26 (GroundSteering)
SERVO3_FUNCTION = 70 (Throttle)
SERVO2_FUNCTION = 73 (Throttle Left)
SERVO4_FUNCTION = 74 (Throttle Right)
PILOT_STEER_TYPE = 1/0 (makes no difference)

Jane,

Did you ever try changing MOT_PWM_TYPE to “0” (and then reboot the board)?

Thanks for try but ja, doesn’t matter what I put that too either.

I just tried a whole new Pixhawk, fresh install of rover 3.4, no motors even attached.

So still can only get a response from Th and Roll (CH3 and 1 on Radio and RC_MAP) on any servo channel set to be GroundSteer.

But what does it say about my config that Groundsteer combo has some sort of mixed/combo response to the TH and Roll channel. But a servo set to respond to TH only does nothing either?

Jane,

Maybe you can provide a dataflash log? It sounds most to me like the vehicle is in Hold mode or disarmed.