Servo Control Problem.

I am getting an issue of my servo Control through my Pixhawk.
Components used:
Pixhawk 2.4.8
GPS Module M8N
Receiver FS iA 10B
Transmitter FS i6X
Telemetry 915 mHz
Servo SG90

I have checked, all my components are working properly. Radio Calibration has also been done and is being reflected properly.
Even on Mission Planner it is being reflected when flicking the switch on the transmitter, but the servo isn’t moving.
What isn’t my servo moving?

You didn’t tell us what firmware you’re using but I’m going to assume ArduPlane. It looks to me like you’ve got power to the servo rail from the BEC. Verify that is working.

The default for arduplane is that servo outputs will not move if the plane is not armed.

You can use the parameter BRD_SAFETY_MASK to set up what servos will moved in a disarmed state. Note, this will not activate throttle channels.

1 Like

Thank you so much Allister! I did the required changes and it worked.

I’m facing the same issue again, even though I did the changes that you suggested. What could be the issue now and how do I go about it?

so it worked, and now it stopped. Troubleshooting 101: What did you do? Compare your parameters now to what you had when it was working. Check the voltage to the servo. Check the wiring. ArduPilot doesn’t just randomly change settings and stop working.

Tell us what you have done to your hardware since you had it working.

I haven’t changed any of my connections at all. Infact I set my parameters to default after it had stopped working and again made the changes that you had mentioned.

please check 5v pixhawk supply and test another sevor motor.

Everything is working perfectly fine by itself, it’s just that the servo is not responding when a switch is flicked on the transmitter.
I have connected the servo to 5 AUX OUT and the BEC to 6 AUX OUT.
And in the transmitter I flick the 5th channel to move the servo.
So which parameters do I change in the Mission Planner for the servo to move?

Servo13_function to chan 5.

What do I set the value of SERVO13_FUNCTION ?

If you were trying to figure this out based on the info supplied what would you choose here?


Probably RCIN5 for the switch 5 on my transmitter.
But before this when it was actually working I changed the params of SERVO5_FUNCTION to RCIN5.

Yes, you got it. If the servo doesn’t move look on Mission Planners Status screen for both ch5in and ch13out.

is this for a Plane?

When moving the switch on the transmitter it is reflected in the Mission Planner but some how it is not reflected on the servo.

So ch5in and ch13out both go high (~2000µs) when you switch it? If so you have a power or wiring problem, the configuration is correct.

And, answer all the questions asked on forum posts. Is this Plane, Copter, what?

Yes, it is for a plane.

So the servo had been working until last week. I feel like this is a transmitter-receiver issue because the last time when the servo had started working i had changed the output mode to PPM/S-bus.

Are there any arm/disarm settings I’m missing out on?