SERVO_BLH_3DMASK makes motors spin 100%


Having some weird issues with my blheli setup. Everything was working fine yesterday but had to restore settings to default after having some sik radio communications issues.

However today I noticed 2 things happening. After changin motor directions using SERVO_BLH_3DMASK I can no longer test the motors individually. If I choose for example to only test motor B all the motors will spin up at 100 percent regardless of what power percentage is selected in the power window. Its currently on 5 %

This also happens when arming the FC with my remote.

It does not matter what channel I choose the motors also refuses to change direction.

All was working as it should before the reset


This also happens when arming the c

Why not try SERVO_BLH_RVMASK rather than 3DMASK to reverse the motors?

I tried that as well and same result.

Even if I untick all the boxes and reboot the motor still spin up to 1000 precent

OK i got it wrong. There was still a box tickted in 3dmask so the motor spinning up to 100 percent is now gone.

However the using RVMASK still does not change motor direction

I have used RVMASK successfully.

Example values:
SERVO_BLH_RVMASK,1280 = reverse motors 1 and 3 (servo9, servo11)
SERVO_BLH_RVMASK,2560= reverse motors 2 and 4 (servo10, servo12)

Do you reboot after you change and if so do you only use MP to reboot or do you disconnect the battery?

You need to fully shutdown/reboot the flight controller. So USB and battery need to be disconnected.

Nope. Not even with that. Simply refuses.

Going to have to use blheli suit. Now to figure out which motor is represented by which ESC on bl heli :slight_smile:

If the reverse bitmask is not working, it’s entirely possible that you aren’t actually using DSHOT at all. Double check your setup from top to bottom.

I thought of that too, but the fact that the 3D mask worked, even if it wasnt required, made me believe that DSHOT was working.

1 Like

dshot commands (e.g. to reverse) are only accepted if you set SERVO_DSHOT_ESC.
also generally doesn’t work with BLHeli_S ESCs

1 Like

Ok I am going to enable that. Maybe its something that I missed. Quick questsion. If I change motor direction in Mission Planner do I only need to do a soft reboot or a hard reboot?

Soft reboot should be ok. But the ESCs retain some state so I would hard reboot to be safe

Thank you very much Andy. Your suggestion was the magic sauce. FYI i just did a soft reboot and that was enough.

Thank you again