Servo activating on system boot?

Hello all. I am having an issue with a “Linear Servo” Every time I boot the system the servo goes to the out position. I have tried to change the PWM, servo reversing and several other things and I cannot seem to get this servo from moving when I boot the system.

Any ideas?

Is this happening when you have a receiver connected and a transmitter on, or when you’re not sending any signal to the Pixhawk?

What is the ‘out’ position in this case? Low/high PWM?

I have a spektrum serial receiver plugged into the “spkt” port. The servo is in the aux1 port. Servo9 is set to “disabled”. The positive pin is powered by a 5v bec.

I turn the radio on first then I power up the quad and the servo (linear actuator) goes to a high pwm position. I want to actuate the servo in the “auto” flight mode so I have not assigned it to a RC command.

My project goal is Im dropping small memory card capsules from a “Pez dispenser” style apperatice that I have created. The linear actuator pushes out a capsule in the high pwm setting and reloads another capsule in the low pwm setting. So when the actuator goes to the high pwm setting on boot up messes up the whole process.

I will be setting auto routes in the jungle delivering these memory cards. I can make a ten mile flight in 25 minutes that takes 6 hours to navigate by canoe. So any help is appreciated.

Ric

Does this mean Servo9_function = 0 ?

–> You could check if your ‘Linear Servo’ does the same when you connect it to a Rx and apply power
–> You could try BRD_SAFETY_MASK
–> You could try Servo9_function = 10 (use camera to trigger)
etc.

I’m still stuck any more help. I have now change AUX1=Camera trigger. when I plug in the copter the servo goes out to a high PWM setting and then cycles back to the low PWM spot. Regardless of the position of the safety switch the servo actuates when I push the trigger button. I don’t want this servo to move when I plug in the copter. Its really pissing me off…

HELP?!?!

Sounds like an issue with that servo type.
Try connecting it to just 5v and 0v, no signal, and see how it behaves…

I have tried that and the servo works as expected. It does not move. The pixhawk is some how telling it to move and I don’t know why.