Serious oscillations while takeoff

I’m using CUAV V5+ with Neo v2pro CAN gps on T.Drone M690PRO quadcopter .
Vibrations are still ok but i have a problem that during takeoff in stabilize mode there is more oscillation in both pitch and roll axis.

but after takeoff it went out and remaining flight were smooth. How to avoid the initial oscillation.

i have set HNCH filter also .

See Pout,Rout and Yout parameters also within the limit.

Upload the .bin log file to s file sharing service and post the link here.

here is the link for log M690 Pro - Google Drive

folder has two file
1.High oscillation : this is initial flight i did with slow throttle raise caused high oscillation.

  1. Little low oscillation : this is second flight with little quickly increased throttle but still caused oscillation while takeoff.
    the same flight used for collect IMU sample to setup the harmonic filter .

I see the oscillations you are worried about.
Sometimes this is due to long or wobbly landing gear, or the ESCs and motors are starting up very fast to a higher RPM than needed.
There’s more tuning to be done though, and it might even be eliminated in that process or at least we will have a better chance of fixing it.

Connect to MissionPlanner and do the Initial Parameters by entering your prop size and correct battery cell information. Accept all the settings it offers and also set BATT_FS_CRT_ACT,1

For the Harmonic Notch filter start with these, then do another hover test flight and just a few gentle movements. Let’s see that log file to verify the correct settings.
INS_HNTCH_ENABLE,1 ← set this then refresh params to see the rest
INS_HNTCH_MODE,1
INS_HNTCH_REF,0.21
INS_HNTCH_FREQ,60
INS_HNTCH_BW,30
INS_HNTCH_ATT,40
INS_LOG_BAT_OPT,2

Once the HNOTCH is working OK you’ll be able to move onto Autotune. Feel free to post a new log at each stage though, so we can help you if required.