Servers by jDrones

Send NMEA sentences to Pixhawk serial port E

Hi,
I’m trying to send synthetic NMEA sentences to Pixhawk (3DR IRIS+) as a fake GPS for indoor navigation, but it seems that Pixhawk doesn’t response to it :cry: . My settings are:
– FTDI cable connect to serial 4/5 on Pixhawk (uartE), with Tx to Rx and Rx to Tx, GND to GND.
– NMEA sentence: $GPGGA,123519,4807.038,N,01131.000,E,1,08,0.9,545.4,M,46.9,M,*47
– baudrate = 38400, stopbit=1, parity=‘N’, from USB port on Raspberry Pi2
– Mission planner parameter setting: GPS_TYPE2 = 5, SERIAL4_PROTOCOL = 1 (also tried 5)
On Mission planner, gpsstatus (uBlox) is 1 since I’m indoor, but gpsstatus2 (FTDI) is 0, no gps detected/received. Could anyone shed a light on the problem? Thanks a lot!
I’ve searched across the forum and seen similar problems, but unfortunately no solid solution was provided…
I was reading through the source code, and in AP_GPS.cpp (line 276) changed it to not skip NMEA, and in AP_GPS_NMEA.cpp directly “return true” in function AP_GPS_NMEA::_detect(…), but still no success… I have tried on Ardupilot 3.4, 3.3, and 3.2.1
Any help would be appreciated!!
P.S.: I also tried to switch the connectors on the two GPS ports on Pixhawk and set GPS_TYPE = 5, GPS_TYPE2 = 2, and it successfully deteced ublox on second GPS port, but no input on first GPS port, indicating both ports are fine, but the setting for NMEA is somehow not working… :frowning:

I am also struggeling with the same issue.
Have you got any solution for this?

I am trying to do the same. Have you found the solution? please help

Servers by jDrones