Semi-Scale JCZK Sikorsky Schweizer 300C Hughes

. . . by Flypro . . . took the plunge . . . now the fun starts :sweat:

1 Like


It’s hard to tell how big the model is. But any good digital servos will work. As will any ESC or motor (I assume it’s electric) that is suitable for the size of the heli. I am not aware of any heli hardware that does not work with ArduPilot.

So there is no real “recommended hardware” - it depends on the heli and how you want to set it up.

For flight controller, any ArduPilot compatible unit will work. There’s a lot of them. The Pixhawk 2.1 is a very good one for bigger heli’s. I recently became aware of the MindPX controller, which is a smaller size that should work good in smaller heli’s. And any of the first generation Pixhawks will work as well as the Pixhawk Mini from 3DR, the Pixfalcon, or Pixracer.

For a full ArduPilot autopilot system you will need the flight controller, GPS/external compass module, and usually a MavLink radio for connection to the ground station.

And study the wiki on how to set it all up.

@ChrisOlson . . . the copter is a 450 size with an 820mm (32.25") main rotor, weighs 60 oz. (3.75#) and runs on a 22.2V 35C 1350mAh Lipo driving a 60A BEC.
Pretty heavy with lots of metal and a ton of socket head set screws.

@ChrisOlson . . . Thanks for the responses Chris . . . went ahead and took the plunge but got the copter completely assembled with the autopilot option already installed. It has a rebranded MiniPix controller.
So . . . now the fun really starts.
When trying to upload firmware via Mission Planner, during initial setup the dreaded “Firmware not suitable for this board” message appears.
Any ideas, other than going with what’s installed? But even then, how do I query what version the board is running? I inserted an SD card but only Home GPS values were stored.
Thanks in advance.
(of course there are larger problems like not being able to Arm, like so many other posts I’ve read)

That board is not supported except in master dev. You have to build your own firmware for it and it only has 1MB flash as far as I know. I think the binaries are still smaller than 1MB building from master, but not by much.

For documentation on building your own firmware you can refer here

And the waf command to configure for that board is
.waf configure --board minipix

It’s kind of a long story about how that board came to be but here’s a thread on it you can follow thru:

Thank you Chris for the info . . . read all your links and my head started to spin and had my doubts about this purchase until I came across the Mission Planner version by RadioLink. Since I have somewhat limited and first experience using MP on a SkyViper V2450 GPS, this did help. Almost feel guilty in asking for advice on an obvious Clone setup that I hope won’t impact the trade deficit in any meaningful way . . . but . . . here is where I’m at . . . have spent days reading and going thru the Ardupilot heli ground school and calibrated this 300C and all servos and throws passed . . . BUT . . . I am still unable to Arm. End of story.
If this bird never flies, at least it’ll make a nice decoration being constructed of nice brushed aluminum and assembled with a ton of socket head cap screws!
I can display any parameters you like to make it easier to diagnose my newbie problem, which I think may be minor.

If you can, why don’t you upload your param file to either here or a cloud sharing service so I can take a look at it. I did not know there is a heli build for the mini pix.

Looks like there are no actual param files stored via Mission Planner by RadioLink, just messages.
Seems I cannot get past
PreArm: Motor Interlock Enabled

Is this the modified Mission Planner supplied by Radio Link? Or is it the ArduPilot developed one? You should be able to go to the Config/Tuning and save the parameters from the Full Parameter List.

RadioLink versus Ardupilot developed Mission Planner

I think the problem is this:

Your SERVO6 output is set up as throttle control. However, you have MIN set higher than RC MIN. Set these to these values and it should allow arming

Also for your RC6 trim set that to 1065 instead of 1933

Sorry Chris . . . made the changes noted and still unable to Arm. Wondering now if I have bigger issues since I cannot, and never have been able to, get the flight board light to stay on steady green, as the instructions from RadioLink state (Step 8):

  1. Power on Transmitter
  2. Select Positioning Mode (Switch G - Middle Position, for Novice)
  3. Enable Throttle (Switch A - Up)
  4. Power on 300C (Press Red Safety Button Until Solid)
  5. Flight Controller Light Flashing Green
  6. Move Throttle Stick to Lower Right
  7. Move Right Stick to Lower Left
  8. Flight Controller Light Solid Green
  9. Disable Throttle (Switch A - Down)
  10. Move Throttle Stick to Lowest Position
  11. Main Blades Start Rotation
  12. Release Throttle Stick (Moves to center, preset to 50% Power)
  13. Wait Until Main Rotor Comes up to Speed
  14. Apply more Power : Takeoff

EDIT: After further review, these steps were not programmed properly on the supplied transmitter.

Yeah, I’m not familiar with this procedure at all. It sounds like they have done something very strange to the firmware here. I don’t know what that Positioning Switch is either with Switch G in middle position for novice.

I am afraid I am not able to help on that one. Since you are running an obvious hacked version of the firmware, can you get support from Radio Link for it?

Thanks for your time . . . I’ll try the RadioLink support and any input from others who may own this heli.
This flight controller didn’t cost me anything in the end so if I replace it with a Genuine Pixracer I’m not out much. I’m new to copter so this is all a learning experience.

btw . . . the Switch G is programmed as a 3 position Flight Mode Switch . . . 1) Manual Self Stabilizing (expert) . . . 2) Position Hold (novice) . . . 3) Position Hold + Headless Mode (novice)