Servers by jDrones

SDP3x airspeed sensor params?


(Lars Meadoworth) #1

What params are needed to use SDP3x sensor with Pixhawk 2? I have it connected to the I2C 2 connection and have params set to pin 65/ use airspeed/ I2C-SDP3x. I’ve tried pin 15 also. I haven’t seen any readings, and I’ve been blowing into it.


(Evan Williams) #2

You may wish to try changing the tube order. There is no guide that I have found on which tube goes where, so I normally have to try one then the other.
If your tube order is “0”, try “1”.

The wrong tube order will result in minuscule readings.

In addition, I would recommend disabling calibration if it was not done automatically when type was set to “6”.

Your offset should be set to zero as well, after disabling calibration.

The Pin setting is relevant only to legacy analog sensors, if I remember correctly.

For my sensor, I have the I2C bus option set to “0” - I believe the bus selection is currently broken, so it ought not to matter.


(Florian) #3

I also had issues using my SDP31. The bus did not recognize the device at all. I figured out that when i set “ARSPD_BUS” to “0” it works without any problems…


(Bosti) #4

My (working) settings fot Drotek SDP33 connected to I2C2:
ARSPD_TYPE = 6
ARSPD_BUS = 0
ARSPD_PIN = 0
ARSPD_PRIMARY = 0
ARSPD_AUTOCAL = 0
ARSPD_TUBE_ORDER = 2
ARSPD_RATIO = 1,9936
ARSPD_PSI_RANGE = 1
ARSPD_SKIP_CAL = 1
ARSPD_OFFSET = 0


(Lars Meadoworth) #5

I got it working thanks to the recommendations. It looks like ARSPD_PIN doesn’t matter, as mentioned, I have it at 65. ARSPD_TUBE_ORDER seemed to matter. When I had it to 2 it didn’t seem to always pick it up. So 0 or 1 seems best. ARSPD_BUS does seem to need to be 0 (internal).