Scripted Aerobatics doesn't work. [SOLVED]

I tried SITL of the scripted aerobatics using the “plane_aerobatics.lua” script, but it does not work. There are messages of “Mission:4 NavScriptTime” and “NavScript time out”. Mission 4 is a simple loop, its SCRIPT_TIME= 2 0 30 0. Except the script the mission went well from take off till landing. I used MissionPlanner and ArduPlane V4.4.0 dev and the MODEL is plane-3d.
Please help me what is wrong!

Did you manage to figure out what was wrong? I am trying to run that script too with SITL and mavproxy but every time it gets to the NAV_SCRIPT_TIME command, it says the same message you get. I followed this video for the mission waypoints: Automatic Aerobatics for ArduPilot - YouTube.

I put the scripts folder in both of these paths but still get the same message: LUA scripts within SITL simulations? and Get UTC time in LUA script - #3 by Georacer

I finally managed to figure out what was wrong. In my case the mistake was fyling the Lua script with .txt file name. I changed it with .lua file name and it went well.

Common error when letting Windows manage downloaded files. Marked as solved.