Scout X4/Win10 - No craft Level when connected to MP via usb

Hi -

I just acquired a Scout X4 and I’m doing the firmware update to v1.1s as per Walkera using Mission Planner.

Mission Planner “sees”, “connects” and aquires all the parameters and says it updated or wrote the new parameter file to the X4.
I need to do an Accelometer calibration as they state but the craft level is not showing.

Is this possibly an Ardu/MP driver issue with Win10?

I did notice the flashing lights that are suppose to come on on the motor arms as seen in all the update videos do not come on. I only have flashing lights on the boards inside the craft that I can see when looking through the battery compartment. (A flashing red and a blue light) Other than that, no flashing lights showing on the craft as stated.

Running Win10x64
Connection via USB to MicroUSB to the craft.

I could us some help as I’m stuck.

Additional notes:
I tried to connect via Bluetooth since it uses MavLink. But can’t get it to connect though I’m paired with it via laptop. Some help there needed as well but will save it for another post if preferred.


  • chase -

While waiting for an answer I kinda solved part of the problem… I think.

It has been recommended not to have the battery in let alone turned on while connected via USB to your comp.

Numerous videos have the battery out with the Scout X4 and the Horizon works as well as the GPS such as seen in this video on YouTube.

As well on the ArduPilot Wiki for Accelometer Calibration page here which you can clearly see the battery is not in while preforming the calibration.

In doing it this way, the horizon is not moving - gps does not show anything.

I found this video on how to do the Accelometer Calibration with the X4 as well.


He has the battery in and turned on.

I held my breath while doing it as I’ve heard a couple horror stories of doing so. And in my case, it did work.
It’s slow as all get out to update the horizon level on this newer comp but it does work.

My question is, why do I have to have my battery plugged in while others don’t for the X4?

And I still haven’t seen the nav lights come on, battery in or out when connected via usb. Nor been able to connect to the Mission Planner via Bluetooth with the BT-2402 that comes with the Scout. Even setting it to Auto. It states there is no Mavlink device. But the BT-2402 is a Mavlink device.

I could still use your help in figuring this out.