Sbus signal. 3.1 and PixHawk

I’m having issues with Sbus signal being seen by PixHawk.

Pixhawk on 3.1(also tried 3.1rc8) on Trad Heli (450)
Tx:Futaba 14SG 14ch mode.
Rx: 7008sb mode 2- comes setup as PWM (mode1) by default
Apm Power Module with 4.8vnicad and ESC at 5v on servo rail.
Mission Planner 1.2.92

Pixhawk is not seeing servo signals in Hardware Calibration screen from RX when plugged into RCin.
Servos and Rx have been confirmed as functioning by plugging direct into RX, operates as normal.
Pixhawk does operate servos(reacts to movement) but not via TX.

Not sure whether this is a PixHawk or 3.1 issue, any ideas?

Now tried 3.1.1Rc1 no change. Rebound Rx and confirmed Mode B. No change.
Any help would be welcomed.

On the 7008SB receiver there are two sbus outputs: sbus and sbus2. Make sure you are using the sbus output. Sbus2 is for Futaba telemetry only.

Definately plugged into SBus port - position 8, not SBus2- hortizontal and below main bank. Shall continue tearing hair out…

Well, it seems to be working now. Did a full Firmware update, and switched on with ARM button depressed- signals now get through and able to Calibrate. Working with Firmware 3.1.1-Rc1 and Futaba 6303sbRX in FaSST Mult.
Thanks to Lorenz for sorting this.