Servers by jDrones

SBUS out questions

Hey guys! I have a question for which I am hoping someone can offer some insight. I have a pixhawk driven Hex that is carrying a nex5 on a three axis gimbal with slipring for 360 degree rotation. Due to limited wiring through the slipring, I only have one set of signal wires to run SBUS to my Alexmos gimbal controller.

What I would really like to have is at least 4 channels running through the pixhawk sbus out in order to control the gimbal. I currently have my ch 8 in/out set to control the gimbal pitch. I set my CH7 in/out as an RC Passthrough to control my shutter on the camera.

I would also like to have a control channel for Yaw, as well as a channel to control gimbal controller modes. My problem is that SBUS out only seems to send out channels 1-8. As it is a hex, my first 6 channels are tied up with ESC motor outputs which only leaves me with channels 7 and 8 to work with. To complicate matters further, I would still like to be able to trigger autotune but I don’t have a channel to trigger it without reconfiguring channel 7 and 8.

I did use a PPM encoder to re-encode the servo outputs from the pixhawk, but it added yet another piece of hardware and also introduced twitches to the pitch control so that didn’t seem to be the best solution.

Does anyone know if there is any way to send channels 8-14 through the SBUS out on a pixhawk or is there a way to switch motors to run on a different set of channels rather than ch1-6? What would be awesome is to just have all 14 of the channels output through the SBUS out port.

Any suggestions?

Can anyone offer any insight on a solution? I cant imagine I’m the only one to have had such an issue.

i think you posted this on rcgroups

but, make a y cable.

go rx and split to pixhawk and then the other to the alexmos.

in the alexmos, you can assign the virtual channels to control whatever.

no need for a ppm converter, unless alexmos doesn’t support ppm

The only help I can offer is that Copter-3.3 supports the 32bit AlexMos controller through a telemetry/serial port although it’s not well tested and we have no documentation on how to set it up. Here are some parameter settings that I think are required:
MNT_TYPE = 3 (to set mount type to AlexMos serial)
SERIAL2_PROTOCOL = 7 (to specify telem2’s protocol is AlexMos serial)
BRD_SER2_RTSCTS = 0 (to turn off flow control for telem2)
After changing these parmeters the Pixhawk (or similar) should be rebooted.

The SToRM32 gimbal setup might give some clues about the setup: copter.ardupilot.com/wiki/common-storm32-gimbal/

For AutoTune, it can be initiated by setting one of the Ch5 flight modes to “AutoTune” (i.e. “15”)

y-harnessing the sbus to the pixhawk and the alexmos 100% works. I set it up today.

i have tilt on channel 6 and pan on channel 12.

i gave the alexmos serial connection a try yesterday. It worked!!! first try, i was surprised. the only issue had had that was when you change MNT_JSTICK_SPD to a speed, the camera movement is choppy, i’m guessing it’s serial communication issue. I didn’t test it out further, i just switched to controlling through sbus. But i’ll give it ago after i get this project done.

@PIEngineering,
I think you’re one of the first people to give the AlexMos serial connection a try. I was wondering, could you give me instructions on how to connect the AlexMos gimbal controller to a Pixhawk? I’d like to create a wiki page on how to do it.

It’s the physical serial lines that I don’t know how to connect so maybe a picture or something would be good. You could mail it to drones-discuss@googlegroups.com.
I know all the parameter settings that are required so that part is ok.

my octo is shipped off right now, when i get it back i can.

but it’s pretty straight forward.

telem 2
G, tx, rx

plug into alexmos uart port.
G,tx, rx

i have a storm on my other quad, but i haven’t tried mavlink or storm serial connection yet. It’s just running on ppm.

I am wondering if should order alexmos
I really want to go with it because encoders look simpler to integrate.
But don’t want to chase my tail getting it hooked up.
So did you get yours working?

I am controlling a SBUS gimbal with the pixhawk SBUS output, using channels 10,11 and 12. All you have to do is set BRD_SBUS_OUT to 1 and Servo10, 11 and 12 to 1 (RCPassThru). Just saying it because no one seems to have posted this simple method.

1 Like
Servers by jDrones