Sbus out functionality... missing? BRD_SBUS_OUT not in my parameters

I’m looking to enable sbus out functionality on a UART. I read the documentation on the wiki page, but when I looked in my parameters I’m missing the BRD_SBUS_OUT parameter. Using a Matek H743-SLIM FC. Hmm…

@CBwintertime,

I think this feature is only supported on CubeBlack, CubeOrange and any of the more powerful H7 autopilots.

For other devs looking to double check my response, I think this feature is controlled by the “AP_FEATURE_SBUS_OUT” definition which only seems to appear in the hwdef file for the boards I’ve mentioned above.

I have SBUS out working with SERIAL1 on my Matek H743 Wing.
I set the SERIAL1 Params like this:

SERIAL1_BAUD,100
SERIAL1_OPTIONS,0
SERIAL1_PROTOCOL,15

Because SBUS is inverted UART, you may need to play with SERIAL1_OPTIONS to invert TX.
In the example above I have an Arduino connected, so I configured normal UART-logic (inverted SBUS) --> SERIAL1_OPTIONS=0

1 Like

Thanks very much @RainFly for helping out. I’ve added to our wiki-4.1 issues list to improve the docs.

@RainFly did you need to enable that BRD_SBUS_OUT parameter, or did it work just by modifying the ones you listed? I was wondering about the inversion also, perhaps that’s my only issue

I think BRD_SBUS_OUT is only for boards with IOMCU processor.
Matek H743 doesn’t have IOMCU, so there is no BRD_SBUS_OUT.
Just set the SERIAL parameter for SBUS out.

@hwurzburg has improved the SBUS out wiki page a bit to hopefully clarify how to set it up using a regular telemetry port instead of the special SBUSo port that some autopilots have.