Servers by jDrones

SB_0000001 Critical service bulletin for Beta Cube 2.1

if you received the cube in 2016, normally it’s part of the beta batch
and i had the same problems with my cube (bad gyro health, compass errors and some others problems)

That’s weird… I looked over everything again, and I don’t see the word “beta” anywhere. Or any mention that what I was purchasing was anything other than a released product. Did they send you a replacement?

Hey there,

I’m using the Pixhawk 2 with Arducopter 3.4.4 Traditional Heli, and changing RC5_FUNCTION to 33 and plugging the servo wire from channel 1 to channel 5 doesn’t have any effect. Is anyone else having the same problem or knows how to fix this?


I’m flying Pixhawk 2 with Copter v3.4.4 and I too received the Pix2 back in November. Today I conducted my maiden and it ended it a crash. The only way I could make the compass variances to go away was by unchecking compass #2. My quad had a tendency to lift the tail at a much faster rate than the nose, first attempt it flipped over. Second attempt I made sure to raise throttle more carefully and still the tail was lifting up way before the nose. I kept on trying to compensate for it until I was able to leave the ground, only to see the quad to start a yaw right rotation and crash land.

@frizensami unfortunately that workaround won’t work with TradHeli in the 3.4.4 firmware, as heli in that firmware controlled its servo mapping directly (unlike multicopter).
If you use the 3.5beta that is out now then it will work. You can set SERVO5_FUNCTION=33 and it will move the first swash servo to channel 5.

@tridge thanks for the help!

Buy my pixhawk 2.1 in November 2016, I received the first batch of January 2017.
Are you affected by this problem?
This is a bit confusing.

I’m a linux person (no MS Windows since 1998) - has the version checking code made it into APM Planner?

Found it - list of affected serial numbers:


Using v3.4.4 as well got same problem and used same solution (unchecking compass #2) however it is a pixhawk clone so this compass problem affects any pixhawk with external compass. I tried on three more similar clones and 2 differents external compass units! Same strange result! While trying, in vain, to calibrate the compasses, I did uncheck the automatic accept boxe and got few thousands samples just to be sure… Did look ok but then on first reboot… got same error… Frustrating! (to stay correct).

I too disabled compass #2&3. No more compass errors.

can termo tape be used ??
Mine was affected and nsulate it by termo tape, I hope that’s do the trick.

Every single unit is affected! there has only been one batch. no confusion.

Not sure what you mean by clone, this is most definitely NOT a clone. same engineers as Pixhawk 1, same team.

It have other corner where a pin is also near the nut, too cautious maybe?

It is marked as a ground pin so I don’t think i t is a problem.

1 Like

Correct, this is ground. Please do not put anything in that corner

Hi @proficnc

Are there any instructions for arduplane users please? Do we still need to move the servo cable from MAIN 1 to MAIN 5? Is there an alternative to RC5_FUNCTION & SERVO5_FUNCTION = 33 for plane?

There’s no output on MAIN 5 for RC5_FUNCTION=33 but there is output for RC5_FUNCTION=4 (aileron) but then it ignores the EVELON_OUTPUT mixing.

Thanks, Tim

The instructions are for all Ardupilot users.

Do not use CH1, until the repair is done.

@tim, are you running latest?

Thank you.

Cool, thanks. I was using plane 3.7.1 but I’ll switch to 3.8.0beta2.

Servers by jDrones