Servers by jDrones

Save trim & auto trim doesn't have effect

arducopter
pixhawk

(Newton Monteiro) #1

after performing these steps http://ardupilot.org/copter/docs/autotrim.html#save-trim

"1. Check that your CH7 switch goes above 1800 on the MissionPlanner’s Hardware > Mandatory Hardware > Radio Calibration screen.

  1. Set the CH7 Option to Save Trim on the Software > Copter Pids screen and press the “Write Params” button.

  2. With your CH7 switch in the off position, fly your copter in Stabilize mode and use your transmitters’s roll and pitch trim to get it flying level.

Land and put your throttle to zero
5. Release the roll and pitch sticks and switch the CH7 switch high for at least 1 second.

  1. Reset your transmitters roll and pitch trims back to the center and fly again and it should fly level now. If it does not repeat steps 3, 4 & 5."

My tricopter continues drift, BUT when I follow 1 at 5 step, and no reset all transmitters roll and pich trims the tricopter fly well

can i fly in auto mode, position hold and loiter with this situation ?

i put the log files to see
https://1drv.ms/u/s!AjRz1CCw8R2dg7AbTXojhdZjy1Bbhg

PICH LINES


ROLL LINES

UPDATE
This are settings in FUTABA T8J for de tricopter fly well

TRIM VALUES

SUB TRIM VALUES


Note i use elavon sub trim for the tricopter don’t fly back when i center the sticks on radio


(Dave) #2

I would not use either of those functions for a multirotor. Center the trims on the Transmitter and don’t touch them. Then do a proper accelerometer calibration. That’s it.


(Shawn) #3

Pay close attention to the level horizon step too.


(Newton Monteiro) #4

i try this, but the result is same, the tricopter continues drift, after use save trim… in some times the results became worse


(Newton Monteiro) #5

hello again… i have a news

i change AHRS_TRIM_X (Roll) and AHRS_TRIM_Y (Pich) for trimed tricopter, with these parameters the drone flies level without drift, but the HUD is not level anymore.
Capturar

currently the values are;
AHRS_TRIM_X = 0,09162576
AHRS_TRIM_Y = -0,3315797

when i use “calibrate level” to level the HUD on Mission Planner, the AHRS values is change and the drone back flies with drift before

this is log file of last fly
2018-05-05 17-25-32.log (893.6 KB)

please guys i need some help here


(Mike Boland) #6

I have had this happen in a Pixracer after an update of firmware.
Tried multiple times to calibrate Accel’s but it still was rolling right nearly to full stick.

In the end I refreshed the firmware and all was well.

Might be something to try.
Have you done the Accel Calibrations?
Both of them?
How balanced is the copter?


(Newton Monteiro) #8

thks…
i will take a check and update of firmaware actualy i have arducopter 3.5.5 this is a last version apears on Mission Planner.

about accel calibration…
After done all the calibrations, moving on all axes,and trims corrections, the tricopter continues flying with drifts, in some cases the result became worst

About the frame…
I use a frame of turning


the battery this installs in the center of the frame all the time, I have never had problems with the trims before, but I have been tried various ways to solve the problem, even bought and changed the pixhawk, but still the problem persists.


(Awad Abdella) #9

Hi Newton_787, I had exactly the same problem and I was wondering if you have found a solution for it?


(Newton Monteiro) #10

i change AHRS_TRIM_X (Roll) and AHRS_TRIM_Y (Pich) for trimed tricopter, after this the drone flies level without drift, but the HUD is not level anymore.


(Newton Monteiro) #11

I update the firmaware and I will try calibrate all acell and level parameters again.